1

I know this is a noob question, so I apologise in advance!

I've been googling for hours, have ran through all the steps for troubleshooting sound through HDMI; un-commenting the config file sound parts, updating sound drivers, forcing HDMI audio output. Nothing seems to work, I was hoping someone here might be able to give me a hint...

Can post any info needed, I am a noob so am not sure what would be required.

Appreciate any help anyone can give me! Am running the latest Raspbian package, on a raspberry pi 2, it is connected to a TV through HDMI. No sound through the jack either.

  • 1
    Have you tried alsamixer? – goldilocks Jun 28 '15 at 11:00
  • think i tried sudo apt-get install alsa-utils, sudo modprobe snd-bcm2835, amixer cset numid=3 2; It can play alsa tests and the speaker test but with no audio – bmacp Jun 28 '15 at 11:54
  • @goldilocks If it helps - lsmod states cfg80211 386508 0 rfkill 16651 1 cfg80211 snd_bcm2835 18649 0 snd_pcm 73475 1 snd_bcm2835 snd_seq 53078 0 snd_seq_device 5628 1 snd_seq snd_timer 17704 2 snd_pcm,snd_seq snd 51038 5 sbd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device joylev 8879 0 evdev 9950 2 8192cu 528365 0 uio_pdrv_genirq 2958 0 uio 8119 1 uio_pdrv_genirq – bmacp Jun 28 '15 at 12:01
  • I meant have you checked the output volume with the mixer. I doubt that is the problem, but it sounds like you've done everything else. – goldilocks Jun 28 '15 at 12:06
  • @goldilocks Sorry! Yeah I have, it's at 50% – bmacp Jun 28 '15 at 12:11
2

Edit the config.txt file by doing sudo nano /boot/config.txt

Either add or uncomment the line "hdmi_drive=2" then ctrl-o to write the changes and ctrl-x to exit the nano text editor. Reboot and the HDMI sound will work.

that worked for me. Actually it had "hdmi_drive=2" remmed out as "#hdmi_drive=2" just had to take out the # and then reboot worked great.

2

I had the same problem found the solution on a forum. Edit the config.txt file by doing sudo nano /boot/config.txt

Either add or uncomment the line "hdmi_drive=2" then ctrl-o and Enter to write the changes and ctrl-x to exit the nano text editor. Reboot and the HDMI sound will work.

1

If you have alsa:

Edit config.txt so that:

hdmi_drive=2 (this forces HDMI mode)

If this does not work try:

hdmi_group=1

or:

hdmi_group=4 (these force CEA mode)

1

If you are having trouble with audio through HDMI, try the following:

  1. Open the "Terminal" in the upper right hand corner.
  2. When it opens, type in: sudo raspi-config
  3. With the down arrow on your keypad, scroll down to 7 Advanced Options and hit enter
  4. With the down arrow on your keypad, scroll down to A9 Audio and hit enter
  5. With the down arrow on you keypad, scroll down to 2 Force HDMI
  6. Use the right arrow on your keypad to highlight and hit enter
  7. Use the right arrow on your keyboard to highlight and hit enter
  8. Reboot your Raspberry Pi and see if your audio now works

If that does not work, try changing your config.txt. To do so:

  1. Reboot your Raspberry Pi
  2. As it is starting up, you will see a screen with a drawing of a raspberry and the words "For recovery mode, hold Shift"
  3. As soon as you see that screen, hold down the Shift key on your keyboard and keep holding it down until a screen comes up with the Noobs menu
  4. At the top there will be a series of icons. One will be a drawing of a pencil and paper labeled "Edit config (e)". Click on that icon and the Config editor will open
  5. Under the config.txt tab of the Config editor, scroll down to the section that says: "# uncomment to force a specific HDM mode rather than DVI. This can make audio work in" "# DMT (computer monitor) modes" "# hdmi_drive=2"
  6. Uncomment the hdmi option by deleting the # in front of it, so the section now reads: "# uncomment to force a specific HDM mode rather than DVI. This can make audio work in" "# DMT (computer monitor) modes" "hdmi_drive=2"
  7. Click OK to close the Config editor
  8. Click the icon at the top labeled Exit (Esc) Hopefully that will work and you will now have audio with your HDMI.
0

I have come across a similar problem when my HDMI cable was plugged in during boot. But when the cable was unplugged at boot time, it worked.

However you should be able to play sound through the OMX Player using the -o option. You can chose between hdmi, local, both, alsa[:device], where local refers to the jack output. So start from

omxplayer -o both file.mp3

to see if it is a software or hardware issue.

0

I've tried every solution in here and i couldn't get the HDMI audio to work. I gave up and put all the options back to how they came by default but then I've found out that when I play an audio file using this command: omxplayer -o both file.mp3, the audio was working so I've decided to give it one more try and I've finally found the solution. None of the things in the config file will affect your audio so I think the best way is to put them back as they were by default and then open a console and do exactly this:

sudo apt-get remove --purge alsa-utils*
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get remove --purge alsamixer*
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install alsa-utils
sudo apt-get install alsamixer
sudo reboot

Then select the HDMI output using the speaker icon in the taskbar and that's it. I hope it works for you!

I've been able to find out this solution because of the omxplayer (that worked) which is a very basic music player that doesn't use the alsa driver, instead it has it's own drivers named openmax, so the problem had to be coming from the alsa drivers.

If it's still not working after doing what I've said above, then you could also try to uncomment hdmi_drive=2 in /boot/config.txt to force HDMI mode. (To do this you have to open up a console, write sudo nano /boot/config.txt and the file will open, navigate down to hdmi_drive and delete the # that's before it, then hit Ctrl+X, hit Y and enter then enter once again. After that reboot the system and pray :))

0

My problem was that I was using the wrong mini-hdmi port. I switched to the other port, put back everything to the original settings and all was well.

  • Share your answer please , not another problem – Sohan Arafat Nov 2 at 8:40
  • @SohanArafat But explaining the problem and giving the answer, like here, is a good answer. – Ingo Nov 2 at 13:39
  • @Ingo that is why comment section is for,,right? – Sohan Arafat Nov 2 at 17:06
  • @SohanArafat I do not understand your comments here to this answer. The first one does not address it. The user shared his answer and you told him to share his answer. So what? – Ingo Nov 2 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.