2

All -

I have followed these instructions:

http://www.mitchtech.net/raspberry-pi-arduino-spi/

However when I get to the last step

sudo ./spidev_test

I never see "HELLO WORLD" in my Serial Monitor console even though my baud rate is 115200.

I did try to run the following command

ls -al /lib/modules/`uname -r`/kernel/drivers/spi/

and it only has two kernel drivers:

  • spi-bcm2708.ko
  • spidev.ko

Could this be the problem ? According to the website I should have two more:

  • spi-bitbang.ko
  • spi-gpio.ko

How would I get a copy of these two drivers it is the problem?

When I run the "spidev_test" program I get some output that says something about "8 bits per word", but no error message.

0

Using bitbang serial port is not great on Pi.

Better disable the console taking up a real UART port on the GPIO and use that instead, as described and explained in this post.

A great add-on card from wyolum will be available soon. I was lucky enough to pre-order to test with my Rev1 Pi's - Can't wait to get it.

enter image description here

  • 1
    Hi ppumpkin - Thanks for the post, but I currently need to work with what I have. I'm starting to think this might be the problem: gammon.com.au/forum/?id=10892 If you look at the link above, the SPI pins for an Arduino 2560 board are 50,51,52,53 not 10,11,12,13 (which are for Arduino UNO). I"m going to try this out and report back to you all. – user1068636 Oct 23 '12 at 14:42
0

I was indeed connecting to the wrong pins. On the 2560 the SPI pins are 50,51,52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.