5
  • I want to run GTK application into my Raspberry Pi Model B(V1.2) board.I'm using Raspbian Debian Whezzy for development.
  • For that i need to install GTK2/3 packages to install.When I'm giving command sudo apt-get install libgtk2.0-dev ,it gives following error,
pi@raspberrypi ~ $ sudo apt-get install libgtk2.0-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed
                 Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
                 Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
  • I've tried to solve that error using command sudo apt-get update and sudo apt-get install -f to fix issues.but not able to solve that issue.

Need help.Thanks

  • Did you try running sudo apt-get update before install ? Also, let us know output of uname -a. – dhruvvyas90 Jul 7 '15 at 7:13
  • 1
    yes..i've written in my question..just check once.. uname -a :Linux raspberrypi 3.18.11+ #781 PREEMPT Tue Apr 21 18:02:18 BST 2015 armv6l GNU/Linux – Ronil Jul 7 '15 at 7:13
  • My bad. and uname -a ? – dhruvvyas90 Jul 7 '15 at 7:17
  • 1
    uname -a : Linux raspberrypi 3.18.11+ #781 PREEMPT Tue Apr 21 18:02:18 BST 2015 armv6l GNU/Linux – Ronil Jul 7 '15 at 7:24
  • I'm able to install it without any problems. But I have an RPi 2 and I'm running latest kernel ie 4.0.6 – dhruvvyas90 Jul 7 '15 at 7:35
5
  • Problem solved. Actually I've made some local change in sources.list file according to local server.Now I've changed it and make it as original.
  • Use sudo apt-get update and sudo apt-get install libgtk-3-dev(for gtk-3) or sudo apt-get install libgtk2.0-dev(for gtk-2) Now its working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.