2

ISSUE

No sound or "Aw, Snap!" message when trying to initiating a webRTC session e.g. http://appear.in, http://opentokrtc.com or apprtc.appspot.com

The video session session seems to work alright despite a lag of a few seconds.

I tried other versions of Chromium to no avail.

If the microphone is muted on the caller side (Mac or PC) the webrtc session initiates and no "Aw, Snap!", but no sound.

The issue happens with out without pulseaudio running.

Any pointers?

ENVIRONMENT

  • Yocto linux distribution for Raspberry Pi2 (armv7).
  • USB Microsoft LifeCam for audio + video capture.

Kernel

root@raspberrypi2:~# uname -a
Linux raspberrypi2 3.18.5 #1 SMP PREEMPT Tue Jun 30 11:29:55 BRT 2015 armv7l GNU/Linux

Audio

root@raspberrypi2:~# pulseaudio --version
pulseaudio 6.0

Setting audio output

root@raspberrypi2:~# amixer cset numid=3 1
numid=3,iface=MIXER,name='Mic Capture Volume'
  ; type=INTEGER,access=rw---R--,values=1,min=0,max=56,step=0
  : values=1
  | dBminmax-min=-20.00dB,max=36.00dB

Modules

root@raspberrypi2:~# lsmod
Module                  Size  Used by
nfc                    55321  0 
bluetooth             280645  2 
rfkill                 17817  2 nfc,bluetooth
ipv6                  334939  30 
snd_bcm2835            20215  3 
snd_usb_audio         104675  0 
uvcvideo               68873  1 
snd_hwdep               5793  1 snd_usb_audio
snd_usbmidi_lib        19271  1 snd_usb_audio
videobuf2_vmalloc       2859  1 uvcvideo
videobuf2_memops        1506  1 videobuf2_vmalloc
snd_rawmidi            17856  1 snd_usbmidi_lib
videobuf2_core         34099  1 uvcvideo
snd_seq_device          5196  1 snd_rawmidi
v4l2_common             5362  1 videobuf2_core
snd_pcm                73756  3 snd_bcm2835,snd_usb_audio
snd_timer              17315  2 snd_pcm
videodev              121448  4 uvcvideo,v4l2_common,videobuf2_core
joydev                  8515  0 
evdev                   9870  3 
snd                    49994  12 snd_bcm2835,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_seq_device
media                  12065  2 uvcvideo,videodev
uio_pdrv_genirq         2916  0 
uio                     7608  1 uio_pdrv_genirq

Installed Chromium

Chromium was built using meta-browser Yocto layer.

root@raspberrypi2:~# /usr/bin/chromium/chrome --version
Chromium 40.0.2214.91

Chromium logs when error

root@raspberrypi2:~#  tail -f /home/root/.chromium/chrome_debug.log | egrep "err|error|errors|fail|fails|failed|problem|issue"
[1215:1215:0701/144149:VERBOSE1:navigator_impl.cc(274)] Failed Provisional Load: https://getkahoot.com/appearin/, error_code: -3, error_description: Unknown error., showing_repost_interstitial: 0, frame_id: 3
[1215:1231:0701/144155:VERBOSE1:resource_loader.cc(321)] OnResponseStarted: https://bam.nr-data.net/1/9175f41998?a=7541921&sa=1&pl=1435761701071&v=632.2b17625&t=Unnamed%20Transaction&be=3336&fe=10696&dc=3426&f=%5B%22err%22,%22xhr%22,%22stn%22%5D&perf=%7B%22timing%22:%7B%22of%22:1435761701071,%22n%22:0,%22dl%22:2413,%22di%22:6761,%22ds%22:6761,%22de%22:12660,%22dc%22:14027,%22l%22:14030,%22le%22:14040,%22f%22:650,%22dn%22:711,%22dne%22:711,%22c%22:711,%22ce%22:2181,%22s%22:799,%22rq%22:2181,%22rp%22:2403,%22rpe%22:2409%7D,%22navigation%22:%7B%7D%7D&jsonp=NREUM.setToken
[1215:1231:0701/144155:VERBOSE1:resource_loader.cc(361)] OnReadCompleted: "https://bam.nr-data.net/1/9175f41998?a=7541921&sa=1&pl=1435761701071&v=632.2b17625&t=Unnamed%20Transaction&be=3336&fe=10696&dc=3426&f=%5B%22err%22,%22xhr%22,%22stn%22%5D&perf=%7B%22timing%22:%7B%22of%22:1435761701071,%22n%22:0,%22dl%22:2413,%22di%22:6761,%22ds%22:6761,%22de%22:12660,%22dc%22:14027,%22l%22:14030,%22le%22:14040,%22f%22:650,%22dn%22:711,%22dne%22:711,%22c%22:711,%22ce%22:2181,%22s%22:799,%22rq%22:2181,%22rp%22:2403,%22rpe%22:2409%7D,%22navigation%22:%7B%7D%7D&jsonp=NREUM.setToken" bytes_read = 41
[1215:1231:0701/144155:VERBOSE1:resource_loader.cc(361)] OnReadCompleted: "https://bam.nr-data.net/1/9175f41998?a=7541921&sa=1&pl=1435761701071&v=632.2b17625&t=Unnamed%20Transaction&be=3336&fe=10696&dc=3426&f=%5B%22err%22,%22xhr%22,%22stn%22%5D&perf=%7B%22timing%22:%7B%22of%22:1435761701071,%22n%22:0,%22dl%22:2413,%22di%22:6761,%22ds%22:6761,%22de%22:12660,%22dc%22:14027,%22l%22:14030,%22le%22:14040,%22f%22:650,%22dn%22:711,%22dne%22:711,%22c%22:711,%22ce%22:2181,%22s%22:799,%22rq%22:2181,%22rp%22:2403,%22rpe%22:2409%7D,%22navigation%22:%7B%7D%7D&jsonp=NREUM.setToken" bytes_read = 0
[1215:1231:0701/144155:VERBOSE1:resource_loader.cc(649)] ResponseCompleted: https://bam.nr-data.net/1/9175f41998?a=7541921&sa=1&pl=1435761701071&v=632.2b17625&t=Unnamed%20Transaction&be=3336&fe=10696&dc=3426&f=%5B%22err%22,%22xhr%22,%22stn%22%5D&perf=%7B%22timing%22:%7B%22of%22:1435761701071,%22n%22:0,%22dl%22:2413,%22di%22:6761,%22ds%22:6761,%22de%22:12660,%22dc%22:14027,%22l%22:14030,%22le%22:14040,%22f%22:650,%22dn%22:711,%22dne%22:711,%22c%22:711,%22ce%22:2181,%22s%22:799,%22rq%22:2181,%22rp%22:2403,%22rpe%22:2409%7D,%22navigation%22:%7B%7D%7D&jsonp=NREUM.setToken
[1249:1291:0701/144208:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000
[1249:1291:0701/144208:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000
[1249:1291:0701/144208:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000
[1249:1291:0701/144208:VERBOSE2:webrtcvoiceengine.cc(2976)] SetOutputVolumePan(0, 1, 1) failed, err=8040
[1249:1291:0701/144209:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000
[1249:1291:0701/144209:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000
[1249:1291:0701/144210:VERBOSE3:webrtcvideoengine.cc(3731)] VP8 options : picture loss indication = 0, feedback mode = 0, complexity = normal, resilience = off, denoising = 1, error concealment = 0, automatic resize = 1, frame dropping = 1, key frame interval = 3000

My launching script with logging enabled

vi /usr/bin/google-chrome 


#!/bin/sh
export DISPLAY=:0.0

export CHROME_DEVEL_SANDBOX=/usr/sbin/chrome-devel-sandbox
export LD_LIBRARY_PATH=/usr/lib/chromium

CHROME_EXTRA_ARGS=" --use-gl=egl --alsa-output-device=plughw:0,0 --use-fake-ui-for-media-stream --enable-logging --v=3 --no-sandbox --user-data-dir=/home/root/.chromium " 

/usr/bin/chromium/chrome ${CHROME_EXTRA_ARGS} $@

NOTE: I am not getting the "Aw, Snap!" when using Ubuntu MATE for Raspberry Pi 2. I compared setups, Chromium versions are different. So I installed the same working version found on Ubuntu MATE onto my Yocto distro for RPi2, and I still get the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.