1

I have tried reinstalling ssh, starting ssh from raspi-config. Nothing seems to be working. When I typed in /etc/init.d/ssh it just goes to another line. No output. The same goes for any cmd like /etc/initd.ssh start

I have also tried regenerating ssh keys. This seems to have started after I install seafile. I am using https on seafile set up. I don't think I have changed any settings regarding ssh. What is wrong with my ssh and What else could I try to start ssh?

enter image description here

  • 1
    have you tried sudo ssh restart? you can also do sudo service ssh status to check if it is running. – Steve Robillard Jul 10 '15 at 2:26
  • I have. It just take the command, and did nothing like in the screenshot. Anything along the lines of "sudo /etc/init.d/ssh whatever" results in just a new line with no output whatsoever. – Roijjer Jul 10 '15 at 2:50
  • 2
    If it's a fresh raspbian, and you didn't change anything, SSH should be enabled by default. To check if service is working, like Steve said, run sudo service ssh status – dhruvvyas90 Jul 10 '15 at 3:49
  • @Roijjer, try and drop the path, maybe it's not the application that you are looking to start (use only 'sudo ssh')? Are you trying to start ssh client or server? – Piotr Kamoda Jul 10 '15 at 6:47
  • Try tail /var/log/syslog after you run sudo service ssh start to see if there is any message there. – goldilocks Jul 10 '15 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.