I am stuck at the splash screen. In the top right of the screen there is an image of a Raspberry.

When I first power on the device, I get the colored screen, and then I get the image of the raspberry followed by a white cursor which quickly freezes or disappears.

I put on the Debian version of wheezy that allows Java. (the soft float version)

I did have it working at one point in time and all I did was go to the terminal (logged out of the GUI) and did a shutdown -h now command. But since then I've even started with a brand new version of the image and it is still not working. Oh and I did try the same SD card with a version of arch linux and it worked fine.

  • Did you recently change the CPU/GPU memory split? Oct 24, 2012 at 17:59
  • Thanks, flagged it to the other stackexchange. Also, I did not make any modifications to the CPU/GPU memory split that I know of. I never messed with any system file or anything. Is that information in that start.elf file or something?
    – Matthew
    Oct 24, 2012 at 19:25
  • Could be errors in the /boot/config.txt file. Can you mount the SD card in another machine to take a look at the files?
    – Jivings
    Oct 25, 2012 at 7:48
  • I'm experiencing the same problem: stuck at the login screen. I input the correct password but after going to a black screen I end up on the same login screen :( I've tried editing config.txt (enabling hdmi_safe=1) but that just changed the resolution and I'm still stuck. Any other suggestions ? Sep 11, 2013 at 12:02

5 Answers 5


I would suggest trying a completely different SD card. That way, you'll know if it's the card or the Pi itself.


Try installing BerryBoot on a fresh, FAT32 formatted SD card while plugged into your router via ethernet (works best) or wi-fi.

You can then either download a fresh copy of the OS over the internet or install it from an SD card... BerryBoot will handle all the configuration steps and partitioning etc. in case the problem you are having occurs through something that is happening in one of those steps.


I would just try re-flashing the same SD card. This has happened to me a couple of times, and re-flashing usually fixes the problem. When this happens, raspi-config often doesn't work properly, either. I have a suspicion it happens when I flash the SD card without first unmounting it properly, but I'm not sure...


I had the same issue. I plugged the sd card into my PC and uncommented the first line of /boot/config.txt (something like hdmi_safe=1) and it started working. It gives low resolution output on the monitor. But, I don't care about the screen resolution since, I will be using it through putty anyway.

  • 1
    Please try and make your answers, sound more like answers and less like a general discussion. Discussions are best kept in the comments, however, your answer is still appreciated. Welcome!
    – Impulss
    Feb 14, 2013 at 6:16

I had the same problem and it was due to the power adapter that I was using. It was a 5v source but the Amp were not right.

It is recommended to use a 5V, minimum of 1.2 Amperes (more current is OK) power supply.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.