0

I have a wireless router and not a LAN CONNECTION.so i want to connect my wifi to raspberry pi using USB wifi dongle and unable to do it.I have tried doing it using wifi_config but couldnt open the browser after connection is made.when i open any browser i get an error "couldnt resolve the host"and When i am connecting the wifi in wifi_config i am getting an error "failed AP scan".so,Please find me a solution and suggest me wht to do. I am using a laptop to get connected to my raspberry pi.

  • Did you install drivers for your dongle? Is it compatible? list of compatible ones – Piotr Kamoda Jul 13 '15 at 8:01
  • No, I didnt install any drivers and the dongle is campatable with raspberry pi. can pls let me know how can i install the drivers as i m not connected to any network. – Sharath Vedala Jul 13 '15 at 8:38
  • There are numerous tutorials on the internet such as this – Piotr Kamoda Jul 13 '15 at 8:44
  • The problem is i am unable to update any thing in my raspberry pi ,it is shwng error in openg the sites and i dont now to get it done.Every procedure i follow has a update.but my raspberry couldnt get updated. – Sharath Vedala Jul 13 '15 at 9:23
  • Use ethernet cable – Piotr Kamoda Jul 13 '15 at 9:25
2

So I suppose your router is connected to internet, which means it can provide internet, what needed is you Pi to ask for an IP address using dhcp discovery message, I'm not experienced about wifi_config so I suggest you to turn it back to default.

Then check interfaces manual by man interfaces, there you'll find many settings for setting the interface settings which are located at /etc/network/interfaces. After that edit the text file interfaces by sudo nano /etc/network/interfaces. Add there a stanza including the details of your router(it's SSID and if exists passphrase. And example I can give to you is :

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
    wpa-ssid "SSID"
    wpa-psk "PASSWORD"

If you turn all the other settings to default, this will work for sure. You can get all the meanings of the lines above from man interfaces and also from another answer that I provided : How to setting up wlan0 that automatically turn on when eth0 is switched off?

  • i have copied wht u have said but the file doest get saved when i prees ctrlX and then y it is showng some other options as M-D,M-A,M-M,etc.butt if iam choosing one of them its showing error "error couldnt write ,such directory doesnt exists" – Sharath Vedala Jul 13 '15 at 9:25
  • just press enter @SharathVedala – Piotr Kamoda Jul 13 '15 at 9:53
  • Press ctrl + O then press ctrl + X it should work @SharathVedala – Tolga Varol Jul 13 '15 at 13:08
  • Of course don't forget to press enter after pressing ctrl + O ** @SharathVedala – Tolga Varol Jul 13 '15 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.