Its seems my Raspberry Pi's Network Preferences program stores its connections in somewhere other then /etc/network/interfaces , where exactly is that information stored at?

I was told it was in /etc/NetworkManager/, but that folder don't exist.

PS: I am using the Raspberry Pi 2 with Raspbian.

2 Answers 2


It should be in /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf.

  • 1
    Problem is that when I changed my static ip address via Network Preferences, there was no change in the /etc/network/interfaces file. So it is likely also in another place, I think. Jul 14, 2015 at 18:41
  • @needoriginalname Tell me about your setup. What's that you're trying to configure ? Is it wifi module or LAN ? Jul 14, 2015 at 18:48
  • Wifi, Its basically a clean setup. I already got the Wifi setup via wpa_supplicant, I had to fill that out manual as the gui does not play nicely with hidden networks. What I want to do is still have the Network Preferences still control how the network works, but I need it to have a pre-set static IP address, and not get one from DHCP. While stilling get the other information from the DHCP. Jul 14, 2015 at 19:04
  • You can't use static and dynamic address on the same interface. It sounds like you may want to look into setting up a DHCP Reservation. Oct 13, 2015 at 13:05
  • Yes, reserving an IP address for a particular MAC (hardware address) is something that (some) modem/routers offer - you have to do it in the routers setup though - typically via a web-browser to the IP address of the router from a connected PC (or Pi) - which IS easier to do via a temporary wired network connection! Then allow the relevant device to use DHCP after all.
    – SlySven
    Dec 18, 2015 at 22:53

You can follow these steps to change the network configuration.

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Dec 19, 2015 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.