1

I got my brand new Raspberry Pi 2 B today and I have a problem very similar to this one: [Solved]Raspberry pi 2 stuck on boot

The boot up stops at exactly he same output. I don't see no rainbow colored square in the upper right corner. Also, this is my second Raspberry Pi 2 B. When i use the new Pis power supply with my old one, the old one boots up and everything is fine. If i try to boot the new Pi with the old ones power supply, it hangs, too.

I only attached a USB keyboard (very simple, no power consuming displays or anything like that) and a HDMI Cable.

Any Idea what's wrong?

Edit:
Used the old Raspberry PIs microSD card with the new Raspberry Pi -> works like a charm. Used the new microSD-Card with the old Raspberry Pi -> same Problem, hangs during boot up. Seems to be an issue with the microSD card. Think i'll have to buy another one.

Edit 2: Yesterday i flashed the new SDcard at least 4 times with raspbian, also tried an older release (2015-02-16), and every time i dd'ed the card back, trunkated the image and compared the originals md5 with that one from the SDcard. The hashes matched everytime.

Today i gave it another try and it suddenly worked. The only difference to yesterday is that i used a different SDCard reader. I tried it again with the first SDCard reader -> didn't boot up, although i veryfied the hashes again. But when i verified the hash of the image written with the old card reader with the second cardreader, they didn't match!

Seems that my card reader is a bit (deterministically) weired.

  • Try re flashing new card with a fresh raspbian and see what happens. – dhruvvyas90 Jul 16 '15 at 3:59
  • Can you post the contents of your config.txt and cmdline.txt. – bennettp123 Jul 16 '15 at 6:34
  • Which card is it? Certain cards don't work with the Raspberry Pi, you might want to check this list here to see if it's a card that's known to have issues. – RPiAwesomeness Jul 16 '15 at 19:23
  • @RPiAwesomeness The card does work if i use the second card reader for flashing. Only the first one does not work out. It's an Intenso SDHC 16 GB Class 10 UHS-I micro SD card. – adalbert Jul 16 '15 at 19:49
  • I've had something similar to that happen before, it's just something wrong with the reader/computer combo I suppose :( – RPiAwesomeness Jul 16 '15 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.