5

I was playing with pi's GPIO a little and then my pi stopped working.

Red LED light is barely visible, other LEDs are off. I left the pi for a day or two alone and the red light got little stronger and green light lit up as well (stays on, doesn't blink) but still no video signal. After some further testing it went back to weak red light only.
After half an hour it's again strong red and green light.

  • I tried disconnecting everything except SD card and USB power cable but it didn't help.
  • I checked the fuse, voltage drop below 0.3 V, seems OK.
  • Tried another cable, plugging it into power adapter and USB, nothing changed.
  • Checked output voltage of power adapter without pi connected, it was around 5 V but when i connect the pi, it drops to 3.5 V.
  • I measured the current drawn by pi ... 1.2 amps?
  • also the main chip gets quite warm, can't keep my finger on it after 30 seconds from power up

Any ideas what is wrong?

  • 4
    Looks like you bricked your RPi. Main processor usually doesn't get that warm. It might have corrupted SD card as well (and USB peripherals you connected). – dhruvvyas90 Jul 16 '15 at 8:56
  • Did you overclock the Raspberry Pi? When it is overclocked, it consumes lots of power and tends to over heat very quickly. If you reinstalled the operating system, and it's the same issue, than this can not be the case. – Mateo Holguin Nov 11 '15 at 20:14
1

Most likley you have shorted one or more of the GPIO pins == there is NO BUFFER between the pins and the Pi cpu chip, so a 'blown to short' is really easy to do.

The other possability is the 3.3v regulator - if you have a multi-meter you can check this on the relevant header pins ...

-1

If this is just 100% CPU usage and not a hardware issue:

  1. Try another NOOBS boot card.
  2. Turn on without the SD card and check.
  3. (Re)Install the latest firmware on the unit. Use rpi-updater (Easy firmware updating tool from Hexxeh). Must point that even with quad full cpu usage, more than one amp is abnormal...
  • ad 1) i don't have another card available but this one seems to be worked before and still seems to be working with my laptop. Tried fresh install, didn't help. ad 2) looks same as with the card: red and green lights glowing ad 3) it worked before so i guess it can not be firmware issue? and i have no idea how to install it from my laptop since pi doesn't boot – Aleš Koblížek Jul 17 '15 at 7:27
  • 1
    -1 He mentioned that he played around with the GPIO. He also mentioned that the red LED is dim. The red LED is usually either on or off only. This clearly signifies a hardware issue. – PNDA Nov 20 '15 at 10:06
-1

Well you could just try an other image to check if it's a software issue (which it is likely not), the pi is not supposed to get that warm while idling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.