0

When I try to log in with my stack exchange credentials from a raspberry pi, the keyboard registers a quotes sign (") instead of an "@" (at) sign. I'm using an Epiphany browser in a Raspbian OS.

  • Have you checked that your keyboard layout is correct? It's probably not if you did not change it when you first installed. – rrirower Jul 16 '15 at 14:27
4

You have a UK English keyboard layout set on your RPi. From this site, you have two options.

Option 1

Run the command:

sudo dpkg-reconfigure keyboard-configuration

Follow the prompts. Then restart your RasPi.

Option 2

Run the command:

sudo nano /etc/default/keyboard

Find the entry XKBLAYOUT="gb" and change gb with, likely us.

Restart

Run the command:

sudo reboot
  • Thanks! I didn't have to try option 2. sudo dpkg-reconfigure keyboard-configuration WORKED Fine. – iDug Jul 20 '15 at 15:18
0

Thanks for the info, I found the "quick & dirty trick" for substitution on the U.S. keyboard layout is shift + double quotes (") to display the @ sign.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.