4

I obtained a ALFA AWUS036NHR with a Realtek RTL8188RU chipset Wi-Fi dongle and I am trying to get it to work on a Raspberry Pi. The device is detected correctly:

root@rpi1:~# lsusb | grep WLAN
Bus 001 Device 004: ID 0bda:817f Realtek Semiconductor Corp. RTL8188RU 802.11n WLAN Adapter

I edited wpa_supplicant.conf according to the manual and then tried to bring up the connection with sudo ifup wlan0 but failed. I looked into /var/log/syslog and saw the following:

Jul 17 15:19:31 rpi1 wpa_supplicant[1728]: wlan0: Association request to the driver failed
Jul 17 15:19:33 rpi1 wpa_supplicant[1728]: wlan0: CTRL-EVENT-DISCONNECTED bssid=9c:80:df:2c:8b:0a reason=0

Seems to be a driver problem. I found a filed issue concerning my case, which is still opened since December 2013. In a referenced pull request there is a message saying "3.19 is no longer updated by us. I've cherry-picked into 4.0 tree." So I updated kernel to latest version using rpi-update, but the issue wasn't resolved. From this point I don't know how to move on and would appreciate any help.

0

Have you tried specifying a different driver (e.g. wext) to wpa_supplicant?

First kill your old process:

# pkill wpa_s

Restart with new driver:

# wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant/your_conf.conf

Start dhcpcd, probably: (maybe kill it first: # pkill dhcpcd )

# dhcpcd wlan0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.