1

I intend to keep an SSH and a Minecraft server up 24/7 (with the exception of the monthly server update). My only problem is, the wifi just stops working after a few hours so I'll have to manually reboot it. This will not be an option in the future. Also, I must use Wi-Fi, as ethernet cables along the floor and in-wall wiring are not currently an option. And for now, neither is moving the Pi.

  • You can make use of a cronjob, which checks if wifi is conencted say, every five minutes. If it is not, it tries to reconnect it. Also have a look at this answers. raspberrypi.stackexchange.com/questions/4120/… raspberrypi.stackexchange.com/questions/8267/… – dhruvvyas90 Jul 18 '15 at 4:10
  • Could I ask what version? Different Pis use Internet cables and 3 is wireless. It is vital. – Devan Vaughn Dec 18 '18 at 2:04
  • @DevanVaughn This was years ago, it was probably a 2B but might've been a 1B. I was using the Wi-Pi adapter at the time, but I don't use Wi-Fi or raspbian on mine anymore. Unfortunately this issue is unresolvable now – robbie Dec 18 '18 at 21:20
0

What wifi dongle are you using ? Edimax ?

Maybe you can change the power managment of your wifi USB dongle : https://www.raspberrypi.org/forums/viewtopic.php?f=26&t=6256&start=1125

  • It's the official fully tested Wi-Pi, I've had it for a few years. Power management is off, and I'm surprised it won't work even with the hub. I think I might have to tinker with it a little. – robbie Jul 23 '15 at 2:29
  • just a sugestion, i have solve my problem like this ;) – Gilles Grandguillaume Jul 23 '15 at 19:35
0

Had a same kind of issue, ended up with a proper USB powering. Used exactly this hardware to mak it go away :

used a power-meter to find a volt-amp dumpings, and - used a power supply, monitoring it at the same time by using an additional USB powermeter

0

You could try using a fixed IP address. Maybe your DHCP lease is expiring.

  • And how would the OP do that? – Steve Robillard Apr 19 '16 at 19:34
  • I'm pretty sure DHCP leases are renewed automatically when expired, provided the connection still works. – Dmitry Grigoryev Oct 21 '16 at 13:28
0

It is a commonly known issue that if the pi is not powered properly , wifi and Bluetooth communication can be very finicky and have a lot of weird symptoms. While it is suggested to have at least a 1amp power supply, I would suggest a 2amp power supply in case you ever decide to add even more peripherals.

0

Disable power management on the wi-fi. See: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=44044

  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Stackexchange answers should preferably stand on their own citing external ressources as references only. – Ghanima Feb 5 '17 at 20:06
  • See here same idea, same rule applies. – Ghanima Feb 5 '17 at 20:06
  • Wow you pound me for just giving a link, then you do the same. but it's ok since you're a moderator I guess. don't worry I won't bother trying to post anything here again. – Yeppers Feb 5 '17 at 21:01
  • Sorry that you're taking this as "pounding". We (goldilocks and I) were merely pointing out the established site rules (on your three relevant posts) that we expect to be followed by all users and thus we are kindly requesting you to follow them too. There is no reason to stop participating here over this. – Ghanima Feb 5 '17 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.