6

Using the Raspbian Wheezy image...

I installed the mono runtime like so on my Raspberry PI:

sudo apt-get update
sudo apt-get install mono-runtime

and it seemed to install fine (If I run mono I get a sensible command output).

Then I started MonoDevelop up up my mac and created a "Hello World" console application (you know, just what you get when you go New Solution | Console Application) - compiled and ran - no problem.

Now I copied the exe over to the PI and was expecting that I could just go:

mono HelloWorld.exe

but when I do so I get this error:

The assembly mscorlib.dll was not found or could not be loaded. It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.

Now I am confused - what have I done wrong and how should I get that DLL? Is there another package I should install?

  • What version of .net is is targeted for. It should not be pipelined either. – Piotr Kula Oct 26 '12 at 9:06
  • Do you have that file (/usr/lib/mono/2.0/mscorlib.dll)? Do you have anything at all in /usr/lib/mono? – Rolf Bjarne Kvinge Oct 26 '12 at 10:55
  • @ppumkin - I am targeting "Mono / .NET 3.5" – kmp Oct 26 '12 at 11:35
  • @SteveRobillard - That worked - thanks!! Maybe post it as an answer and I will accept it – kmp Oct 26 '12 at 11:35
4

You need to install the mono-complete package (which includes the mscorlib.dll file); to do this enter the following at the command line.

sudo apt-get install mono-complete
-2

In my case I was writing the wrong name of the HelloWord.exe file. When I wrote correctly i.e. mono Helloword.exe, it worked fine. However the error was the same one

  • 1
    If mono HelloWord.exe report some missing dll, the problem is somewhere else. – mpromonet Feb 23 '15 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.