1

I am trying to set up the "Blinky Lights" project with Google Coder v0.9. I have used the code from the example project, unaltered, as well as setting up my breadboard exactly as the instructions describe. However, nothing works. I am getting an error that looks like

SERVERLOG: "Could not write to pin: EACCES"

I have looked online, but haven't found anyone with a similar problem.

Could it have something to do with permissions? Does anyone know how to fix this?

  • 4
    I suppose someone will search for google coder and blinky lights. For those of us that won't a few links would have been useful. – joan Jul 20 '15 at 4:29
  • Are you running it with sudo? You need root access to get to the GPIO pins. – ifermon Jul 22 '15 at 20:25
  • I have tried running it with sudo. I am aware that you need root access to use the GPIO pins, but this still doesn't work. – Jasper Holton Jul 28 '15 at 0:47
  • I have found a workaround by having Node.js from coder run shell scripts on the pi to change the pins, but I still can't do this using coder. It seems to be broken in the new build, and I haven't found a solution. – Jasper Holton Jul 28 '15 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.