2

I'm trying to set up cron to turn off networking on my Raspberry Pi during the night (from 23:00 to 8:00).

The problem is that none of this commands do the job:

$ sudo service networking stop
$ sudo ifconfig eth0 down
$ sudo ifdown eth0

From the output it looks like the command worked but the interface is still up (I can ping 8.8.8.8 and it's present in ifconfig).

This is the content of /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

output of ifconfig (masked MAC)

eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1545 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1054 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:117138 (114.3 KiB)  TX bytes:156391 (152.7 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1104 (1.0 KiB)  TX bytes:1104 (1.0 KiB)

output of route -n

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    202    0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     202    0        0 eth0

The outputs of ifconfig and route -n are the same before and after the 3 commands

Any help?

  • Try adding service ifplugd stop as well. – goldilocks Jul 22 '15 at 14:30
  • @goldilocks still not working – Matteo Jul 22 '15 at 14:42
  • And you are sure those commands are actually being executed? I would put them in a script together, piping output to a file, as well as logging $? (status of last command). Note that stuff run by the system cron shouldn't use sudo, it is run root anyway. – goldilocks Jul 22 '15 at 14:45
  • @goldilocks Have a look: dropbox.com/s/lpb5dkyaccq6xir/… – Matteo Jul 22 '15 at 14:54
  • Since you aren't using wlan0 and wlan1 can you comment those stanzas 4 lines each and then try again? – Tolga Varol Jul 22 '15 at 14:56
-1

What about:

/etc/init.d/networking stop

  • I get "[...] deconfiguring network interfaces" but nothing changes, still on – Matteo Jul 22 '15 at 14:35
  • What you've written is basically same as service networking stop – Tolga Varol Jul 22 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.