1

I have to communicate to a device which uses serial interface through the USB port. I disabled the Serial Port Login and disabled the Bootup Info. When I list the devices using lsusb, the device is detected. ls /dev/tty* lists a number of tty , but no ttyUSB is listed. There is no change in the list before and after I connect to the device. ttyAMA0 is listed before and after the device is connected. In the window PC the device is detected in COM5. How do I know the port to which it is connected. I have a java application that sends and receive data to the device.

dmesg | grep usb gives [ 3732.485108] usb 1-1.5: Product: ROTOR-GENE

[ 3732.485126] usb 1-1.5: Manufacturer: Silicon Labs [ 3732.485142] usb 1-1.5: SerialNumber: 120876

The device link is qiagen.com/us/shop/automated-solutions/sample-prep/rotor-gene-q

The device is connected to the USB port though internally the USB interface is connected to a USB-to-UART bridge.For programming purposes this means that the interface appears as (virtual) serial interface (RS232).

  • Can you get us device link ? Looks like driver is not available in built. You will have to install it manually. – dhruvvyas90 Jul 24 '15 at 13:25
  • 2
    Compare tail /var/log/syslog immediately before and after you plug in the device. – goldilocks Jul 24 '15 at 14:09
  • Also post output of lsusb. You device must be listed there. – dhruvvyas90 Jul 24 '15 at 15:23
  • You do not need to disable serial port login and boot messages. They only appear on /dev/ttyAMA0 which is the gpio base serial UART. No need to do anything special for serial over USB. – joan Jul 24 '15 at 17:15
  • A thought. Are you actually talking about a USB dongle plugged in to a PC connected to the Pi's gpios. If that's the case you are using /dev/ttyAMA0. A photo of your set-up would help. – joan Jul 24 '15 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.