1

My Pi is connected to my network and can ping outside (google, cnn, etc.), however it's inet addr from ifconfig isn't pingable from my laptop on the same network. Can someone please help me understand what I may be missing on a new Pi running Raspbian? I've only configured wpa_supplicant with my network ID to get on my wifi network.

I'm not using a static IP addr yet, I'm just using the wlan0 IP - it should work as long as I don't reboot and DHCP doesn't assign it a new one.

There's only one other StackExchange question that deals with this, and it doesn't address my problem - my wifi dongle doesn't sleep or otherwise disconnect from the internet.

Using arp-scan from either the Pi or my laptop show the other devices and router on the network, but interestingly not each other.

  • Are both your laptop and RPi connected via wifi? If so, some wifi routers have privacy features that do not allow wifi-connected devices to see each other. If everything is working except for wifi-connected devices communicating amongst themselves, this might be worth looking into. – bobstro Jul 25 '15 at 5:42
  • Do you have access to router ? If yes, you can see your device listed in dhcp client list. – dhruvvyas90 Jul 25 '15 at 5:50
  • That's interesting. I don't see the DHCP client list, but even just looking at my network list I do see the Pi with its current IP addr and it shows as "active" with IP addr allocation type of DHCP, so it's definitely on the network (again, as expected - from it I can ping anywhere). Update: So I just did a ping test from my router and it works... so it really is a device-to-device connection I'm missing, and have no idea why. – user33121 Jul 25 '15 at 10:24
  • I found the feature user bobstro hinted at in my own router. It is a checkbox labeled "The WLAN devices displayed may communicate with each other". It is below the list of WLAN devices. – user33140 Jul 25 '15 at 23:48
  • Could you share your internal IP address? Also which OS and version of it are you running? – brianlmerritt Dec 23 '15 at 14:14
1

The setup of your wireless is huge in this scenario. Are you using a public wifi (such as a workplace wireless) or a local wifi (such as your home)? If using the former, there is a high chance that there is a security setting preventing the two devices from seeing each other. If you manage to get this working, you might run into troubles later, as protocols such as ssh are most likely disabled as well.

1

Ping Failures: Without any granular details about IP addressing & firewalling- you've not given much detail- I'd suspect that ICMP is being blocked somewhere in either a host firewall or the AP FW connecting the Pi & laptop.

Interpreting Arp Cache Output: A quick discussion on interpreting arp cache results when investigating connectivity issues might help your troubleshooting efforts:

A) Only hosts within the SAME subnet can be seen in an arp cache: If you ping a device on a different subnet, only the pinging device's router GW IP will be shown in the arp cache of the host responding to the ping- not interface of the pinging host's interface.

gateway (192.168.1.18) at d4:ca:6d:XX:XX:5e [ether] on eth0
gateway (192.168.3.126) at d6:ca:6d:XX:XX:26 [ether] on wlan0
pi3Bplus-camera2 (192.168.1.22) at b8:27:eb:XX:XX:3c [ether] on eth0

Pinging FROM my laptop on a different subnet TO the Pi only shows the laptop's GW IP (192.168.3.126) in the Pi's arp cache.

But pinging a Pi at 192.168.1.22 FROM another Pi in the SAME subnet on 192.168.1.21 shows THE PI's .22's interface; they're within the same subnet so it resolves to a host rather than a GW in the arp cache.

So even though my laptop pinged the Pi successfully, you can't see it's IP in the Pi's arp cache.

B) Another reason a host might not appear in an arp cache even within the same subnet (even if it connected successfully) is if you reboot a host or restart its' networking: arp caches are not persistent across reboots or networking restarts. You'd lose any historical record of host connectivity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.