1

Since a while I was using rpi-source to download kernel source corresponding to the kernel update using rpi-update.

As it works great on kernel

Linux pib 3.18.14+ #793 PREEMPT Sat May 30 13:15:19 BST 2015 armv6l GNU/Linux

It doesnot work with kernel

Linux pi2 4.0.7-v7+ #801 SMP PREEMPT Tue Jun 30 18:38:23 BST 2015 armv7l GNU/Linux

On such a kernel it reports :

ERROR:
gcc version check: mismatch between gcc (4.8.4) and /proc/version (4.0.7)
Skip this check with --skip-gcc

Help: https://github.com/notro/rpi-source/wiki

A workaround is to add the --skip-gcc as the script suggests it.
How to run it without skipping this check ?

1

The script rpi-source extract the gcc version parsing /proc/version with :

gcc_ver_kernel = re.findall(r'\d\.\d\.\d', proc_version)

And use the first matching occurrence as the gcc release of the current kernel.

This works only if the kernel version doesn't match '\d.\d.\d' and gcc release does. It is correct till the kernel identification have almost one release number with 2 digits.

Update :
The problem was fixed this since this commit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.