0

I have a Raspberry Pi Model B, Revision 2.0 and a Raspberry Pi 2 Model B. Use PuTTY and xming on a Windows PC works fine to the Rasp Pi 2, but on the Rasp Pi 1, I get “cannot open display” when I run Midori or Geany. I read a bunch of posts on this problem and tried all the suggestions but have not found the answer. Any ideas?

0

1 Answer 1

0

If you'll do a DHCP table Reservation lookup, on your router, you'll notice, default names for both Pi's will be the same(no generational name differences; only OS's are named differently). Make sure the settings in PuTTy: Under left side are:

"Category" -->

SSH-->

X11-->

check off "Enable X11 forwarding"

Without that set, the X-window system cannot find your Pi for display. Save the configuration by typing a name (i.e.Pi_1) in the box under 'Saved Sessions' on the Sessions screen. Press the Save button to save the configuration. Click Open to open the terminal window or Cancel to close PuTTy. The next time PuTTy is run, the session named Pi_1 will be shown. Select Pi_1 with the mouse and click Open to launch.

2
  • The two Rasp Pi's have different IP addresses and I am referring to them by those IP addresses in Putty, so I don't think they can be confused.
    – Peter N
    Jul 26, 2015 at 2:29
  • Putty has am entry for each IP. "Enable X11 forwarding" is set for both.
    – Peter N
    Jul 26, 2015 at 2:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.