1

I have a raspberry pi 2 with a GoerTek bluetooth USB Dongle from dx.com, and I've been trying to for hours to make a connection between my Samsung Galaxy S5 and my raspberry pi, through an app I made using MIT App Inventor. the app is simple, it just has a bluetooth client that tries to connect to another paired device, and once a connection is made, it's supposed to put text on a button in the app to tell me it's connected. my raspberry pi and my phone are already paired, and I've been using the command sudo rfcomm listen hci0 as I press connect on the app, which worked the first time I tried it, but hasn't worked since. Also, whenever I tell my phone to connect to the pi, inside the 'Bluetooth Devices' window on the pi, I can see an orange, a green, and then a blue bar show up to the right of my phone's name and icon, then disappear around 2 seconds later. Then, my phone will say, 'Error 507: Unable to connect. Is the device turned on?'. I've also tried having the pi request a connection with the command sudo hcitool cc xx:xx:xx:xx:xx:xx with the App on the phone trying to recieve the connection, with no luck. However, for some reason, I've been able to send a file to my phone from the 'Bluetooth Devices' window on the pi without any problems. I'm pretty inexperienced with App Inventor and raspberry pi, so if anyone could help, it would be much appreciated. Thanks!

  • Power could be an issue here. What size supply are you using (output amps)? You should have a look at tail -n 50 /var/log/syslog immediately after the pi seems to drop the connection. – goldilocks Jul 26 '15 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.