2

After upgrading to Jessie, watchdog doesn't start at boot anymore. Starting it manually using "sudo service watchdog start" does work. I tried:

  • purging and reinstalling watchdog
  • update-rc.d

I checked

What else can I try?

  • 1
    You should include the exact update-rc.d command you used, what your default runlevel is (runlevel will tell you), and then what priority update-rc.d assigned in the init directory for that service (those are /etc/rcN.d, where N is the runlevel; the priority is the number prefixed to the service file link). You might also want to try systemctl list-units | grep -i watchdog to see if you can use systemd directly for this instead. – goldilocks Jul 26 '15 at 14:34
  • My runlevel is 5, the priority also is 5. I used sudo update-rc.d watchdog defaults and sudo update-rc.d watchdog enable. The output of systemctl is empty. – BenjaminH Jul 27 '15 at 13:38
  • You might want to about this on Unix & Linux. Include all the details you have here, including the fact that update-rc.d did work because /etc/rc5.d/S05watchdog exists (that's all update-rc.d does, so that is not the problem, presuming that is the name of the link you found). – goldilocks Jul 27 '15 at 13:51
3

Over at Unix & Linux Ineb answered:

Open

/lib/systemd/system/watchdog.service and add 

[Install]
WantedBy=multi-user.target

Systemd needs the [Install]-Section for a Unit to know how it should enable/disable the Unit.

After that calling systemctl enable watchdog worked.

  • [Install] section is there, but service doesn't start automatically. What to do? – Paul Dec 14 '17 at 21:50
  • 1
    Normally systemctl enable watchdog should do this. Is there any output when you try to enable the service? – BenjaminH Dec 16 '17 at 12:31
  • sudo systemctl enable watchdog Synchronizing state for watchdog.service with sysvinit using update-rc.d... Executing /usr/sbin/update-rc.d watchdog defaults Executing /usr/sbin/update-rc.d watchdog enable. And /etc/init.d/watchdog status shows active (running) when started manually. Then I make reboot and ... Oh gosh! It is active! Thank you, but I don't know why it worked this time. – Paul Dec 17 '17 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.