0

Background & what I have tried:

I have been working with 2 Raspberry Pis and everything has been working fine with both until today. Today when I went to power up the one that I normally used (connected to the same monitor that it had been connected to as before) and when the Pi received power, the PWR LED indicator did not come on, but the ACT LED indicator is solid, and no video was pushed to the HDMI display.

I also tried a freshly imaged SD Card (same brand and same size as the one that I tried to boot with first) to no avail. I did check the second SD card on the second Pi to make sure the image was good, and the second Pi successfully booted into Raspbian.

I also tried the first SD Card in the second Pi, and the Pi states

---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

...after displaying a lot of messages (http://imgur.com/a/LqzMa, sorry some of those are illegible).

My questions:

  • What could be wrong with the first SD Card (The one that gave the end Kernel panic error)?
  • What could be wrong with the first Raspberry Pi that is causing it not to output video?

UPDATE:

I have gotten the SD Card with the end Kernel panic error to successfully boot on the Raspberry Pi that was not having any issues (Found my Ubuntu Live USB Stick and ran fsck on each part of the SD card). The first Pi still will not push video, even using a LG Micro-USB Phone Charger. I also cannot SSH into this rPi (definitely enabled SSH access, and cannot see this Pi's IP address using arp -a since it is on a subnet of my laptop).

  • What is the size of the power supply (output volts & amps) and what peripherals are connected to the pi beside the monitor? – goldilocks Jul 28 '15 at 18:41
  • The power supply is coming from my laptop's designated USB charging port, which I am pretty sure that is not causing the problem as the second Pi was able to boot fine from the same USB port. I currently have no other peripherals connected to the Pi. – Burn_E99 Jul 28 '15 at 18:45
  • You should test with a different (1+ A) supply. USB ports are only required to put out 500 mA, which is borderline. That means it will not consistently fail, but may sometimes. Bad power may cause filesystem corruption; you should check the partitions with fsck. – goldilocks Jul 28 '15 at 18:49
  • I currently do not have any USB power supplies with me (currently at work, will try that tomorrow), but the USB port that I am currently using has worked for the past month with no problems at all. (Link to my laptop's specs for the USB port: shop.lenovo.com/us/en/laptops/thinkpad/x-series/x140e/…) I do not have any Linux machines to run fsck on the SD Card, but if I run chkdsk (Windows equivalent of fsck), this is what is returned: pastebin.com/PW4434Y4. – Burn_E99 Jul 28 '15 at 19:10
  • Windows will only be able to check the first (boot) partition, not the root filesystem. Obviously you won't be able to find out whether the pi is damaged or not until you have another supply to test with. – goldilocks Jul 28 '15 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.