1

I followed this link to install PyQt5 on Raspbian. First I cross compiled Qt5 (this link) for Raspberry and executed an example. It worked fine.

When executing this command:

python configure.py --qmake ~/Qt5.3.1/5.3/gcc_64/bin/qmake --sip-incdir ../sip-4.16.5/siplib

I received the following error:

Querying qmake about your Qt installation...
/usr/local/qt5pi/bin/qmake: 1: /usr/local/qt5pi/bin/qmake: ELF: not found
/usr/local/qt5pi/bin/qmake: 2: /usr/local/qt5pi/bin/qmake: Syntax error: word unexpected (expecting ")")
Error: PyQt5 requires Qt v5.0 or later. You seem to be using v3. Use the
--qmake flag to specify the correct version of qmake.

Did I do something wrong?

2
  • Are you running the python configure.py command on your Raspberry Pi? Jul 31 '15 at 19:26
  • yes,I run: python configure.py --qmake ~/Qt5.3.1/5.3/gcc_64/bin/qmake --sip-incdir ../sip-4.16.5/siplib. and if I run python configure.py without any arguman it say: Error: Use the --qmake argument to explicitly specify a working Qt qmake Jul 31 '15 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.