10

I am following the instructions from Using PowerShell to connect and configure a device running Windows 10 IoT Core to access my Raspberry Pi 2 with Windows 10 IoT via PowerShell.

PS C:\> Enter-PSSession -ComputerName minwinpc -Credential minwinpc\Administrator

This then opens a window where I enter the default password.

Then after about two minutes, it fails with

Enter-PSSession : Processing data from remote server minwinpc failed with the following error message: The WinRM
client cannot process the request because the server name cannot be resolved. For more information, see the
about_Remote_Troubleshooting Help topic.
At line:1 char:1
+ Enter-PSSession -ComputerName minwinpc -Credential minwinpc\Administrator
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (minwinpc:String) [Enter-PSSession], PSRemotingTransportException
    + FullyQualifiedErrorId : CreateRemoteRunspaceFailed

The Raspberry Pi 2 is, of course, up and running and I can access the website at http://minwinpc:8080

The development PC has windows 8.1 and is in the same subnet as the Raspberry Pi 2.

I already tried all the steps with the IP address instead of the hostname, but it gives the same error.

  • can you try adding the -Port flag and adding the port (check firewall settings on your machine(s) and router, sometimes these things are set to disallow remote access.) – Havnar Aug 13 '15 at 12:08
  • Are you using x86 powershell ? I encountered similar problem when using x64 powershell, but using x86 didn't show the issue. – silwal Sep 17 '15 at 16:50
  • Did you solve this issue? – Piotr Kula Jan 13 '16 at 22:54
  • nope, still stuck. – clamp Jan 14 '16 at 18:31
2

I had the same problem.

I visited this link - Setting up Windows 10 for IoT on your Raspberry Pi 2 - and cut/paste code to connect from there on to the powershell - it connected fine.

net start WinRM
Set-Item WSMan:\localhost\Client\TrustedHosts -Value MINWINPC
remove-module psreadline -force
Enter-PsSession -ComputerName MINWINPC -Credential MINWINPC\Administrator

Only difference was the remove-module psreadline -force line.

Wondering if that caused issues - How can I get an interactive login with Windows 10 IoT Core running on a Raspberry Pi?

  • I guess (not using Windows or PowerShell) it is connecting using SSL (not sure since isn't mentioned anywhere) and if so there's a certificate/host check, an you're using a full uppercase host name for TrustedHosts, this could make the difference – Alex Aug 15 '15 at 7:46
  • thanks, i tried that additional line, but it gives me this error: remove-module : No modules were removed. Verify that the specification of modules to remove is correct and those modules exist in the runspace. – clamp Aug 15 '15 at 12:11
1

I think Alex is Correct I closed and start power shell again and only difference I did was set the PC name all lower case (as its actual named)

net start WinRM
Set-Item WSMan:\localhost\Client\TrustedHosts -Value minwinpc
Enter-PsSession -ComputerName minwinpc -Credential minwinpc\Administrator

Did not use this line

remove-module psreadline -force
0

I had the same issue, I reformatted my SD card(using Diskpart) and then reinstalled the IoT core OS and ran Powershell and this time I didn't perform the code line: remove-module psreadline -force after it when I booted my device on the core watcher and deployed a solution to it, It works just fine and Powershell works as well after the deployment of the first program.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.