I'm sorry to say that I'm a complete newbie to linux and Raspberry Pi. I installed Raspbian on my pi years ago and just started working with it again.

I'm trying to install kodi on my system but after the regular install via apt-get and trying to start I get "error while loading shared libraries: libmmal_core.so: cannot open shared objekt file: No such file or directory".

I've tried about everything I could find online; can't seem to find anything though. Here https://www.raspberrypi.org/forums/viewtopic.php?t=51925&p=415168 was an idea I wasn't able to try out simply because I had no idea what the guy in the last post was talking about.

Any help? The file cannot only not be found but doesn't exist at all.

up vote 3 down vote accepted

You need to determine:

  1. If the library is present (it should be).

    The path is /opt/vc/lib. If that's not there or doesn't contain that library, run sudo rpi-update and make sure it at some point says "Updating VideoCore libraries".

  2. If the library is in the linker path (it should be).

    For this:

    ldconfig -p | grep libmmal
    

    You should see it listed. If not

    echo /opt/vc/lib > pi_vc_core.conf
    sudo chown root.root pi_vc_core.conf
    sudo mv pi_vc_core.conf /etc/ld.so.conf
    sudo ldconfig
    ldconfig -p | grep libmmal
    

    It should be there now.

  3. What kodi actually links to.

    I believe the binary is in a weird spot because it's started via a script. Try:

    ldd /usr/lib/kodi/kodi.bin
    

    What you don't want to see there is ????? after libmmal_core.so. =>

  • THANK YOU! It took me hours without results and the only problem was the rpi-update... I was close to redoing the whole OS. Probably should have done that... Now I'm not getting that problem anymore but just nothing happens after I type in "kodi". Guess I can take it from there though. Thanks again! – Exxi Aug 4 '15 at 17:37
  • 1
    Problem solved; used tightVNC and that one doesn't stream kodi. Just to leave that here – Exxi Aug 4 '15 at 18:12

For me the solution was simply installing libraspberrypi0:

sudo apt-get install libraspberrypi0

Note that rpi-update shouldn't be necessary nowadays, as updates are included in raspberrypi-kernel and raspberrypi-bootloader.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.