1

I tried to Setting up Auto-login on my raspbery pi, but not with success.

I changed /etc/inittab line:

1:2345:respawn:/sbin/getty 115200 tty1

to

1:2345:respawn:/bin/login -f pi tty1 </dev/tty1 >/dev/tty1 2>&1

But I must have made a mistake. Can anyone guide me, to how i can change my /etc/inittab back to normal?

I have no idea how i can get into a terminal.

0

I have no idea how i can get into a terminal.

You can't now, you'll probably have to take the card out and edit inittab on another computer. You haven't applied this to runlevel 1, so "single user mode" should still be feasible, but there's no way to enter it without also editing the card. Normally, bootloaders provide a way to interrupt so you can choose to boot in single user mode, either with a preconfigured option or by specifying appropriate parameters for the kernel command-line, but the pi is a special case and there are no such choices.

If you have sshd installed and working, you should be able to get in that way; I think the rest of init's services would still have completed normally, and the respawning is throttled/disabled so the processor should not be overburdened.

There's also a serial console, but you'd need a special cable to hook that up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.