7

Is there any way to get an install the gnuradio binaries on raspberry-pi?

At the moment, I am running the build script that took 2 hours on my core i7 1.6 GHz quad core Xeon. I have a UHS-1 45Mb/s Sandisk Extreme card in place and that does not seem to be helping speed up the process either :-/

Update: After several hours and many attempts, the build script failed as it could not find libraries with prefix libfftw. Nevertheless I did install them. If I cannot get binaries, how do I successfully compile it?

Update @2012-10-31 21:40 UTC: I installed fftw and fftw-dev before the build script could proceed any further.

Update @2012-11-01 03:16 UTC: After a few trials, I managed to get the error rounded up here is the screen shot - https://www.dropbox.com/s/2e4dqkximyz2o5p/20121031_220814.jpg?m

Update @2012-11-01 03:43 UTC: A little bit of search got me a patch file. The problem was originally reported here. However, while applying this patch, I discover that it has already been applied to the git repository. So that is another dead end :-(

Update @2012-11-01 16:43 UTC: I tried to compile it with the the neon disabled

cmake -Dhave_mfpu_neon=0 -DCMAKE_CXX_FLAGS:STRING="-march=armv6 -mfpu=vfp -mfloat-abi=hard" -DCMAKE_C_FLAGS:STRING="-march=armv6 -mfpu=vfp -mfloat-abi=hard" -CMAKE_CXX_FLAGS "-fexceptions" -CMAKE_CXX_COMPILER "/usr/bin/arm-linux-gnueabi-gcc" ../

And ended up getting consistent errors at 37% - "Internal Compiler error - file bug report"

Update @2012-11-02 12:20 UTC: I finally got it to compile. It might be that the lack of memory was causing problems along with other things. Increasing the swap space helped.

https://www.dropbox.com/s/nll0qhm4z09vvgk/gnuRadio-RPi.tar.gz is the built binary. Should anyone want to try these, let me know if it works.

3
  • If storage space/speed is a concern, consider mounting up a remote nfs(or other network file system), and use that for compiling. Or plug in a (faster) USB key. As for libfftw, did you install the libfftw3-dev package, not just libfftw3 ?
    – nos
    Commented Oct 31, 2012 at 21:05
  • I had installed every package that started with libfftw3. Nothing worked. Finally I installed fftw and fftw-dev and the build script proceeded beyond. This is still building. I'll update the question if something from this takes me any further.
    – Lord Loh.
    Commented Oct 31, 2012 at 21:39
  • Looks like the compiler is running out of memory... cross-compile. Commented Nov 1, 2012 at 19:50

1 Answer 1

2

I successfully built & installed GnuRadio following the instructions here: http://www.hamradioscience.com/raspberry-pi-as-remote-server-for-rtl2832u-sdr/

I don't recall there being any particular trick to it, but if you get stuck, post up any errors here and I'll see if it jogs my memory.

Consensus seems to be that the Pi isn't powerful enough to do GnuRadio stuff standalone, but is useful as capture source (and then accessed over TCP).

1
  • 1
    The instructions on the link are to install RTLSDR and not GNURadio. I managed to install RTLSDR and use it without any hitches. It is the GNURadio and GNURadio Companion that I am looking forward to install.
    – Lord Loh.
    Commented Oct 31, 2012 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.