1

I recently tried to extend the functionality of my RPi to serve as a gateway through the (LogMeIn) Hamachi client.

Yet the RPi has been used as a wifi hotspot (with static ip for both, wlan0 and eth0 interface) through an adjusted routing table, isc-dhcp-server and hostapd service.

I used the following commands to install the given hamachi client:

  1. sudo apt-get install lsb-core
  2. sudo dpkg -i logmein-hamachi_2.1.0.139-1_armhf.deb (previously downloaded from the hamachi page)

After adding the client to the according Gateway-Network (within the LogMeIn central) and defining him as the gateway computer, I can't access the internet through my wifi anymore.

Note: If I define him as a simple network member, all is working fine, except for the missing gateway functionality.

Here is the ifconfig output before and after gateway assignment:

[before]

eth0 Link encap:Ethernet HWaddr b8:27:eb:d4:45:cb inet addr:192.168.0.12 Bcast:192.168.0.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:50449 errors:0 dropped:500 overruns:0 frame:0 TX packets:37562 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:50402536 (48.0 MiB) TX bytes:11077575 (10.5 MiB)

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

mon.wlan0 Link encap:UNSPEC HWaddr C0-4A-00-11-A6-65-00-00-00-00-00-00-00-00-00-00 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1492 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:207946 (203.0 KiB) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr c0:4a:00:11:a6:65 inet addr:192.168.42.1 Bcast:192.168.42.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:38568 errors:0 dropped:0 overruns:0 frame:0 TX packets:50936 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:10930199 (10.4 MiB) TX bytes:52102904 (49.6 MiB)

[after]

eth0 Link encap:Ethernet HWaddr b8:27:eb:d4:45:cb inet6 addr: fe80::ba27:ebff:fed4:45cb/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:93010 errors:0 dropped:1660 overruns:0 frame:0 TX packets:63709 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:88368876 (84.2 MiB) TX bytes:16586853 (15.8 MiB)

ham0 Link encap:Ethernet HWaddr 7a:79:00:00:00:00 inet addr:25.111.169.0 Bcast:25.255.255.255 Mask:255.0.0.0 inet6 addr: fe80::7879:ff:fe00:0/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1404 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:8 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:0 (0.0 B) TX bytes:648 (648.0 B)

ham1 Link encap:Ethernet HWaddr 00:23:c3:6f:a9:00 inet6 addr: fe80::223:c3ff:fe6f:a900/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1404 Metric:1 RX packets:28 errors:0 dropped:0 overruns:0 frame:0 TX packets:17 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:1680 (1.6 KiB) TX bytes:1116 (1.0 KiB)

ham-br0 Link encap:Ethernet HWaddr 00:23:c3:6f:a9:00 inet addr:192.168.0.12 Bcast:192.168.0.255 Mask:255.255.255.0 inet6 addr: fe80::ba27:ebff:fed4:45cb/64 Scope:Link inet6 addr: 2a02:810d:8800:4630:ba27:ebff:fed4:45cb/64 Scope:Global UP BROADCAST RUNNING MULTICAST MTU:1404 Metric:1 RX packets:132 errors:0 dropped:0 overruns:0 frame:0 TX packets:106 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:17593 (17.1 KiB) TX bytes:14531 (14.1 KiB)

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:12 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:2544 (2.4 KiB) TX bytes:2544 (2.4 KiB)

mon.wlan0 Link encap:UNSPEC HWaddr C0-4A-00-11-A6-65-00-00-00-00-00-00-00-00-00-00 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:4787 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:672816 (657.0 KiB) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr c0:4a:00:11:a6:65 inet addr:192.168.42.1 Bcast:192.168.42.255 Mask:255.255.255.0 inet6 addr: fe80::c24a:ff:fe11:a665/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:62203 errors:0 dropped:0 overruns:0 frame:0 TX packets:81248 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:15953838 (15.2 MiB) TX bytes:78108272 (74.4 MiB)

Only thing I can see is that there's no assigned IPv4 for eth0.

How can I fix this, in order to get the gateway as well as my wifi hotspot up and running?

  • I have the same problem in ubuntu, after a vpn conection the interface ham0 shows in the ifconfig, I dont know how to remove that – user41754 Feb 19 '16 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.