2

I was following Keiki's instructions and got stuck on the Debian image. Although I installed it successfully; I just can't see it on my hard drive (using Windows). I can check it with qemu-img but it is simply not there.

H:\Program Files\qemu>qemu-img info C:/debian.img
image: C:/debian.img
file format: qcow2
virtual size: 1.5G (1572864000 bytes)
disk size: 639M
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: false
    refcount bits: 16
    corrupt: false

-

C:\>dir
 Volume in Laufwerk C: hat keine Bezeichnung.
 Volumeseriennummer: B4B0-B3B5

 Verzeichnis von C:\
29.07.2015  11:50       330.301.440 debian-8.1.0-i386-netinst.iso
21.07.2015  21:58                 0 f7d61fe20641c15cfe08fe5db177e675
31.07.2015  16:18    <DIR>          Games
21.07.2015  03:36    <DIR>          Intel
10.07.2015  13:04    <DIR>          PerfLogs
27.07.2015  21:02    <DIR>          Program Files
26.07.2015  17:05    <DIR>          Program Files (x86)
21.07.2015  03:51    <DIR>          Users
05.08.2015  10:39    <DIR>          Windows^

Update

Not even:

C:\>dir /A:H /B
$Recycle.Bin
bootmgr
BOOTNXT
Documents and Settings
Dokumente und Einstellungen
hiberfil.sys
MSOCache
pagefile.sys
ProgramData
Programme
Recovery
swapfile.sys
System Volume Information

is able to reveal it while it definetely takes up disk space as i can resize it using qemu-img

1

The image is probably at H:\Program Files\qemu\C:/debian.img (windows path), if anywhere. I think you have mixed up the /s and \s - probably in this step:

  1. Create image using qemu-img.exe create -f qcow2 G:\debian.img 1500M(smaller size should be suffient too).

Make sure you use \s in the path not /s - Windows paths use \, and are usually relative to the disk they are on - e.g:

On windows systems

Path to folder on root (C) filesystem

C:\Program Files\

Path to file on a mounted volume

D:\work\stuff.odt

Linux systems use /

On Unix/Linux systems (like Raspbian)

Path to folder on root (C) filesystem

/usr/share/

Path to file on a mounted volume

/run/media/WORKUSB/work/stuff.odt

Other things:

  • ./ current directory (linux) (proably %CD% on Windows)

  • file:///run/media/WORKUSB/work/stuff.odt

  • Already thought of that as well but nothing's in there either. – mystery Aug 8 '15 at 19:41
  • If you still have a cmd prompt in the window with qemu info, try using the windows copy command to copy the file to where you can see it (perhaps copy /v C:/debian.img C:\debian.img). The file may also be hidden – Wilf Aug 8 '15 at 19:51
  • The file cannot be found in both direcotires (C:\ and qemu in \program files) – mystery Aug 8 '15 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.