Today is my first day with Pi. I don't have a monitor or keyboard around, but that's okay.

I managed to install a Raspbian image (without NOOBS so I could access cmdline.txt), mod cmdline.txt to set the on boot ip, and use ssh and an internet cable to log in to my pi.

Everything was going great. But then I decided to try and run the GUI and use VNC Viewer to use it from my laptop.

What I think I did wrong was changing a setting in rasp-config to default booting to desktop mode because suddenly the SSH I had running at the time stopped working and I can't get it working again. Nor does the ip it should be using ping when I use nmap.

I'm not sure if there's something awful going on it there (like it crashes when booting in desktop mode vs. command line), or it simply no longer uses cmdline.txt when booting in desktop mode, or most of all how to get access to it again.

Any advice would be wonderful.

Thank you

1 Answer 1


Something to be aware of when it comes to using tools like raspi-config is that the tool will overwrite many of the configuration files you modified yourself when you first setup the Pi with SSH.

The easiest answer to this is to reflash your SD card and start over. You're not so far in (or are you?) that this isn't a viable option.

But if you're in too far and reflashing your SD card seems too draconian, you should be able to enter single-user mode and make whatever changes you need to. However, you will need a display, a keyboard and another computer with an SD card reader (which you ostensibly used when you flashed the SD originally).

Follow these instructions and you should be able to reverse any changes and get your Pi back.

  • I decided to go the restart route. I think I might have been able to SSH using the default IP, but it's unverified. For now, I'll call the question answered and cross my fingers that nobody ever needs a better answer. (and sorry if you do!)
    – Seph Reed
    Aug 11, 2015 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.