2

I have RPi model B+ and I don't have access to any other electronic device other than my laptop! I've read almost every other question regarding this. After copying the image to the sd card using win32diskimager. I turned it on and waited for almost an hour, then connected the ethernet cable and tried finding it on my network, I found a new device with this ip : 169.254.121.49 I've read that ssh is already available is raspbian. I tried to connect using putty, a lubuntu VM and MobaXtreme all resulting ssh access denied (wrong password). I've tried any combination of the words raspberry, pi, raspbian, raspberrypi for password with "pi" and "root" usernames. is there another password I should try or there's something else wrong? It's been almost a week since I've been stuck with this. please help me! This is the output from MobaXtreme: enter image description here

and when I connect it to my laptop this new connections is add which has the following IP: enter image description here

I did a whois on the IP which stated that it's a reserved address for physically connected local devices.

  • 1
    Could you edit your post and show how you are prompted when you try to putty to the Pi. The prompt will let us know whether you are talking to a Raspberry Pi or not. – joan Aug 11 '15 at 13:30
  • If you have another linux system with an SD card reader (or any system that can work with ext4 filesystems; Windows and OSX require third party software for this; you could also use a linux live CD or VM, which are not that hard to set up), you should look through /var/log/syslog for evidence that the pi was online and sshd was running. – goldilocks Aug 11 '15 at 15:28
2

The default user is pi with the password raspberry.

So you could do ssh pi@169.254.121.49 -p 22 from a unix machine or the equivalent of this command from Putty.

Mind you that 169.254.121.49 doesn't look like a private network IP on first sight. Check your router for new IP's in your LAN

If 169.254.121.49 is indeed public you need to forward port 22 which most ISP's don't allow.

EDIT after question update:

Since there is no DHCP/DNS in your network your computer and PI will both self-assign an IP address. (The 169.254.xxx.xxx IP address space is reserved for self-assigning or link-local IP addresses. They are used when your device is not connected to any network at all or a network that has no DHCP server, so that devices can assign their own IP address.)

The subnet should be 255.255.0.0, check if you arn't trying to SSH into your windows machine (open a cmd windows and type ' ipconfig /all ' without the quotes).

If you are sure that 169.254.121.49 is the IP of the PI and not your laptop, check your laptop's network port settings and make sure you are in the same range and try again.

workaround:

If you can access the SD card directly, try to set a static IP on the ethernet port of the PI. Set a static IP on your ethernet port of your laptop in the same range and try ssh again using the command above and replace the IP with the PI's IP.

  • Thank you for your answer but as I have stated in the question I have tried this. Also I'm connecting through a LAN cable directly and there is no router or ISP involved – Arian Soltani Aug 12 '15 at 18:47
  • I have updated my answer. – Havnar Aug 13 '15 at 7:35
0

A new OS generally has the ethernet in DHCP mode meaning it is expecting your laptop to assign an IP to it.

Connect the SD card to your laptop and be sure you are able to access the SD card on your lubuntu VM

type sudo nano /etc/network/interfaces

Change iface eth0 inet dhcp to iface eth0 inet static

Below this line type [replace x with the values of your choice]

address 192.168.2.1
netmask 255.255.255.0
gateway 192.168.2.2

press ctrl+x and then 'y' to save the file.

Once this is done remove the SD card

On your windows computer give it a static address like below

address 192.168.2.2
netmask 255.255.255.0
gateway 192.168.2.2

and now power your raspberry pi. You should now be able to SSH into your Pi like stated in your question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.