I have my Raspberry Pi 2 since a week and noticed that little rainbow on the top right corner of the screen.

Seems like this is a alert for under voltage. I tried different power supplies and my best one is a "Anker" 30W. It's just impossible that the Raspberry Pi needs more power than 30W. I also tried different cables... so it must be a Raspberry problem.

All I have plugged in the USB ports is a keyboard.

The Raspberry is running chromium which needs a lot of energy...

So my question is: Is it possible that the Raspberry Pi needs more energy but has something like a max voltage regulator which doesn't allow more? Or is this just a bug? Or maybe that rainbow has also another meaning?

I know that I can turn off these warnings but fear that the SD card corrupts.

  • 3
    The rainbow warning means the 5V line has dropped beneath 4.65V. What voltage do you measure at the Pi?
    – joan
    Commented Aug 11, 2015 at 16:54
  • i wans't able to check on that by now.. My question is more like "is it in general possible that the raspberry needs more power than it can take from the power supply even if the power supply can provide more than enough"
    – 1i0ny
    Commented Aug 11, 2015 at 17:35
  • 2
    More than enough what? Electrical power has characteristics other than just work per unit of time (wattage). You could provide more than enough potential volume (amperage) but with not enough force (voltage) to make it usable. Air compressors are a good analogy. You can have a tank and hose with lots of volume, but another aspect of what determines the rate at which it can be delivered is the pressure differential between the tank and the destination (=voltage). Beware I'm not a physicist, lol, you can find other explanations online.
    – goldilocks
    Commented Aug 11, 2015 at 18:04
  • yea sure.. im aware of that but i thought a good power supply should have something like a voltage stabilizer..
    – 1i0ny
    Commented Aug 11, 2015 at 18:09

3 Answers 3


The Raspberry Pi 2 has a 2.2 amp polyfuse which limits the power which may be supplied via the microUSB socket. This is more than enough to power the Pi and the USB sockets.

Initially the USB sockets can only draw 600 mA. At worst this leaves 1.6 amps for the Pi2 and anything connected to the gpios.

By changing a setting after boot software can configure the USB sockets to draw up to 1.2 amps. At worst this leaves 1 amp for the Pi2 and anything connected to the gpios.

You haven't mentioned connecting anything to the gpios or the USB.

The only meaning to the rainbow square in the top right of the screen is that the 5V line has dropped beneath 4.65V.

If you trust the power supply to be accurate the other cause of low voltage is thin wires in the microUSB cable.

  • Thanks you. My best power supply is this one: ianker.com/product/71AN7105SS-WA pretty sure that this is a good one.. I also tried different cables..
    – 1i0ny
    Commented Aug 11, 2015 at 18:02
  • 1
    You will need to try a known good voltmeter to check the actual voltage at the Pi. That's the only way to be sure. It is possible, but unlikely, that you have a faulty Pi.
    – joan
    Commented Aug 11, 2015 at 18:11
  • Hmm my Raspberry also throws some wild gpio errors while booting.. It never stops until I kill the power.. It happens rarely but this might also indicate a defective Pi.. Sadly I don't have a voltmeter right now but the only explanation I can think of is a defect..
    – 1i0ny
    Commented Aug 11, 2015 at 18:15
  • It may also have to do with the "Power IQ" feature: "amp-adjustment technology intelligently identifies your device to deliver its fastest possible charge". If this sets the amperage, assuming a device which is going to draw a constant or otherwise predictable amount of current (as charging would), then when the pi gets busy, the additional current draw might cause a voltage drop. Of course, if you tried with other decent supplies that don't have this feature, that's not the problem.
    – goldilocks
    Commented Aug 11, 2015 at 18:16
  • 1
    @1i0ny What are these wild gpio errors? How do you know they are occurring? What have you got connected to the gpios?
    – joan
    Commented Aug 11, 2015 at 19:37

I know this is an old port. However in my case the problem was solved by replacing the USB cable, not the power supply. Give it a try

  • Yeah, good point - the PSU can be putting out a nice, well regulated 5.00V precisely but if the USB to micro-USB lead is a particularly poor example of the species you can lose volts along the wires in it if those wires are thin and have a significant resistance - the bigger the current drawn the bigger the volt-drop. To add to this loss is the main "Polyfuse" in the 5V supply rail on the RPi which does introduce a small extra resistance into the circuit as a side-effect of how it works (and, if it ever trips, that resistance will probably never return to being as small ever again!)
    – SlySven
    Commented Jan 18, 2016 at 11:43

I had the same problem when i used my PSU with the charging cable from my Kindle.

The problem was that it was a 2m cable. The only way i was able to fix it was by using the shortest cable i had: 5 cm.

If you don't trust your pi, that it is right about its voltage readings, you can use a multimeter to measure the voltage on the 5V GPIO pins to GND. If that is below 4.65V you are too low on voltage.

  • I also confirm i solved the same problem with cable replacement on a pi3 B. Thank you guyz
    – cxristos
    Commented Jun 18, 2017 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.