1

I am currently facing the problem that the i2c-dev kernel module is not loaded despite the dtparam=i2c_arm=on being present in /boot/config.txt. Therefore I cannot i2detect fails on me as /dev/i2c-1 is not present. After I execute modprobe i2c-dev it seems to work just fine. Currently, I am running the latest version via raspi-update and have updated all packages via apt-get upgrade. Does anyone know how to fix this issue without doing something like executing modprobe i2c-dev on start up?

2

I don't understand device tree well enough to say if this is intended behaviour or a bug.

Device tree loads the driver (i2c_bcm2708) but does not create the devices.

You need to modprobe i2c_dev to create the devices.

Normal procedure is to have the line i2c_dev in /etc/modules so it is modprobed at boot.

| improve this answer | |
  • Thank you very much, that worked for me. But it still appears as if it really should work without this as it is never mentioned in instructions about the new device tree settings. – D0r1an Aug 12 '15 at 20:44
  • @D0r1an The chap who seems to maintain the Raspberry Pi device tree should be aware of the issue. I'm fairly sure I've raised it although perhaps only tangentially. See raspberrypi.org/forums/viewtopic.php?p=675658#p675658 for some history. – joan Aug 12 '15 at 21:07
  • @D0r1an Now asked and answered at raspberrypi.org/forums/viewtopic.php?p=801866#p801866 – joan Aug 13 '15 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.