0

When trying to solve this problem here How to fix perl : warning : setting local failed http://stackoverflow.com/questions/31990851/how-to-fix-perl-warning-setting-local-failed-on-raspberry-pi?noredirect=1#comment51889438_31990851

i run

sudo dpkg-reconfigure locales

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US.UTF-8",
        LC_ALL = "en_US.UTF-8",
        LC_PAPER = "fr_FR.UTF-8",
        LC_ADDRESS = "fr_FR.UTF-8",
        LC_MONETARY = "fr_FR.UTF-8",
        LC_NUMERIC = "fr_FR.UTF-8",
        LC_TELEPHONE = "fr_FR.UTF-8",
        LC_IDENTIFICATION = "fr_FR.UTF-8",
        LC_MEASUREMENT = "fr_FR.UTF-8",
        LC_TIME = "fr_FR.UTF-8",
        LC_NAME = "fr_FR.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg-query: package 'locales' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: locales is not installed

so i run this command to install locales

sudo apt-get install locales

    Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2-mpm-prefork : Depends: apache2.2-bin (= 2.2.22-13+deb7u5) but it is not going to be installed
 apache2.2-common : Depends: apache2.2-bin (= 2.2.22-13+deb7u5) but it is not going to be installed
                    Depends: apache2-utils but it is not going to be installed
                    Depends: procps but it is not going to be installed
                    Depends: perl but it is not going to be installed
                    Recommends: ssl-cert but it is not going to be installed
 libbz2-1.0 : PreDepends: multiarch-support but it is not going to be installed
 libc6 : Breaks: locales (< 2.19)
 libcomerr2 : PreDepends: multiarch-support but it is not going to be installed
 libdb5.1 : PreDepends: multiarch-support but it is not going to be installed
 libgcc1 : PreDepends: multiarch-support but it is not going to be installed
 libgssapi-krb5-2 : Depends: libkeyutils1 (>= 1.4) but it is not going to be installed
                    Depends: libkrb5support0 (>= 1.12~alpha1+dfsg) but it is not going to be installed
                    PreDepends: multiarch-support but it is not going to be installed
 libk5crypto3 : Depends: libkeyutils1 (>= 1.4) but it is not going to be installed
                Depends: libkrb5support0 (>= 1.12~alpha1+dfsg) but it is not going to be installed
                PreDepends: multiarch-support but it is not going to be installed
 libkrb5-3 : Depends: libkeyutils1 (>= 1.5.9) but it is not going to be installed
             Depends: libkrb5support0 (= 1.12.1+dfsg-19) but it is not going to be installed
             PreDepends: multiarch-support but it is not going to be installed
 libmagic1 : PreDepends: multiarch-support but it is not going to be installed
 libpcre3 : PreDepends: multiarch-support but it is not going to be installed
 libssl1.0.0 : Depends: debconf (>= 0.5) but it is not going to be installed or
                        debconf-2.0
               PreDepends: multiarch-support but it is not going to be installed
 libxml2 : Depends: liblzma5 (>= 5.1.1alpha+20120614) but it is not going to be installed
           PreDepends: multiarch-support but it is not going to be installed
           Recommends: xml-core but it is not going to be installed
 locales : Depends: glibc-2.13-1
           Depends: debconf (>= 0.5) but it is not going to be installed or
                    debconf-2.0
 php5-common : Depends: sed (>= 4.1.1-1) but it is not going to be installed
               Depends: psmisc (>= 22.15-1~) but it is not going to be installed
               Depends: lsof but it is not going to be installed
               PreDepends: dpkg (>= 1.16.1~) but it is not going to be installed
 tzdata : Depends: debconf (>= 0.5) but it is not going to be installed or
                   debconf-2.0
 ucf : Depends: debconf (>= 1.5.19) but it is not going to be installed
       Depends: coreutils (>= 5.91) but it is not going to be installed
 zlib1g : PreDepends: multiarch-support but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

i neeed some help please

11
  • Have you recently run ( sudo) apt-get update and apt-get upgrade?
    – joan
    Commented Aug 15, 2015 at 11:45
  • @joan yes !!! i run them a lot because every time i install some new packages and recently i installed mongodb
    – The Beast
    Commented Aug 15, 2015 at 11:55
  • Perhaps it is a temporary repository problem. It happens sometimes. Have you installed any non-repository software?
    – joan
    Commented Aug 15, 2015 at 12:05
  • Edit in your /etc/apt/sources.list.
    – goldilocks
    Commented Aug 15, 2015 at 14:02
  • @joan No i don't think so
    – The Beast
    Commented Aug 15, 2015 at 23:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.