0

I bought 16 GB and 32 GB micro SD and I have a problem:

Raspbian is booting properly but when I went to GUI, desktop wallpaper has been displayed, coursor started flickering, disk LED was blinking like crazy but after 5 minutes nothing happened, I was blocked...

I had UHS-I card and everything worked great but I lost it :/

I have 2 RPi2s, both has the same problem. What can I do ?

  • I've used a lot of crappy old cards on the Pi and still have to find one that gives up on me. But there probably are unsupported/broken cards around. I'd reformat the card properly (with the overwrite flag) with the SD Card Tool, burn the image and run raspi-config to expand the filesystem. If it still crashes after this, your card probably is due for replacement. – EDP Aug 19 '15 at 10:45
  • But it's just not able to start GUI :/ – Nicolas Aug 19 '15 at 11:10
  • I can expand filesystem, I can create python script on desktop I can run it, I can do everything in console byt GUI is not working.. – Nicolas Aug 19 '15 at 11:30
  • On both cards and RPis. – Nicolas Aug 19 '15 at 11:30
  • Have you tried to download and burn disk image once more? Have you tried any other OS? – avra Aug 19 '15 at 13:00
0

From what I can gather from your comments, I would suggest to re-download the rasbian image, reformat the SD cards (back up what you need first) and try again.

  • Tried 3 times, I had to use NOOBS :/ Clear image should work, and It was but without GUI, weird... – Nicolas Aug 19 '15 at 16:15
  • Very specific rarities like this are usually related to something that got corrupted on the SD card or image. You should also check your power supply. It might sound strange but if your Pi doesn't get enough power it will misbehave in the strangest ways and your SD card might get corrupted as well. You need 5V 2A and a not-too-long USB cable (long or bad quality cables make for power loss). – Havnar Aug 20 '15 at 8:06
  • I have 5V 2.5 and 1 A Power Supplies and I tried on both (first that stronger), on both the same situation :/ I have 10 cm cable XD Btw. 2 SD Cards corrupt exactly the same, in the same time ? – Nicolas Aug 20 '15 at 8:31
  • are you using the exact same downloaded image then? The corruption might be in there. (PS: when using a GUI in some OS's on the Pi2 models [not sure on other models] you see a rainbow square in the upper right corner, this indicates that the Pi isn't getting enough power) – Havnar Aug 20 '15 at 9:38
  • I'm using exactly the same image fresh downloaded from raspberrypi.org ... I didn't see that square – Nicolas Aug 20 '15 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.