2

The last thing I did was to install upstart and then try to restart my raspberry Pi. The install looked to be fine and then I posted a shutdown command:

sudo shutdown (I think it was)

I left it a while to turn off and I think it had done so when I disconnected the power to turn it back on again. From there I couldn't SSH into the device again. I was able to ping the Pi from my desktop, and it responded. So... on connecting the Pi to my TV via HDMI I got the following messages:

"transcript of the on-screen messages":

fsck from util-linux 2.20.1

dosfsck 3.0.13, 30 Jun 2012, FAT32, LFN

There are differences between boot sector and its backup.

Differences: (offset:original/backuo)

65:01/00

Not automatically fixing this.

/dev/mmcblk0p5: 14 files, 19558/120958 clusters

FAT-fs (mmcblk0p5): Volume was not properly unmounted. Some data may be corrupt.  

Please run fsck.

So.... hopefully I don't need to totally reformat the SDCard and loose everything on there. Are there any suggestions on a solution to this at all?

  • That sounds like the first FAT32 partition is corrupted - which you could run even Windows Scandisk on or the Linux fsck.vfat -f -r -v -V. I do have a dual boot PC and I sometimes get this issue with a FAT32 partition that sometimes reports this if I have had a crash. (I have a suspicion that THAT particular byte is one that tells Windows if the disk was cleanly unmounted.) Your difficulty is if you only have the Pi to work on - a separate PC (the one you SSH from) with a card reader/writer should enable you to make some progress. – SlySven Dec 15 '15 at 0:00
  • So, I've tried running Windows Scandisk on the SD card, and it reported: "Windows successfully scanned the drive. No errors were found." I then ejected the drive and tried to boot the pi, but with no luck. The same error messages come up as previously. Is this possibly something to do with Windows only seeing the first, boot partition on the drive at all? Would a Mac be able to see multiple partitions on the same device? If so, which mac utilities might help with this issue? – Adrian Schmieder Dec 15 '15 at 15:05
  • Well I thought it was only the first partition - which is all that a Windows machine may see (also an I thought!) - but now I'm wondering... As for a recent Mac - yeah I think that would see it (with it's unix internals) - fsck should handle it from a command line, thought you will need an argument or two to force it to fix things, (use --help to see what might be needed). Hopefully there will not be any data loss. 8-) – SlySven Dec 15 '15 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.