0

I have a RPi 2 running OpenELEC 5.95.4 that is connected to my router via a 100 Mbit/s LAN cable connection and I am trying to watch 1080p internet video streams via the New York Times add-on.

The internet connection, however, is really slow. The CPU power cannot be the bottleneck: The CPU is almost in idle mode while the video is running. Watching blu-ray DVDs over the network works fine, too.

My Win 7 PC loads 1080p internet streams like a charm, so my internet bandwidth cannot be the bottleneck, either.

Any ideas what might be the problem?

Edit:

I ran a few tests and found out that no matter whether I download files via wget from a dedicated Internet-based test server or whether I stream video data, the Pi's download speed does not exceed 1.1 MB/s. However, when I download media from the local network, speeds are much higher. Any suggestions how to fix this? I am using OpenELEC's default configuration.

  • You mean you have established cable connection no wireless connection? – Chinmaya B Aug 25 '15 at 11:18
  • @Creator: Right, I used a CAT 6 Ethernet cable. I edited my post to make it clearer. – Lexxer Aug 25 '15 at 12:11
  • You need to clarify whether the internet connection is really responsible for this by, e.g., testing it specifically in a browser. If you get 20+ Mbps, the problem is perhaps in the application. – goldilocks Aug 25 '15 at 15:06
  • Perhaps there is a reason why every OpenELEC add-on I know uses only 780p video stream quality, not 1080p: The Pi might not be able to handle more data. Or is there anyone who can download at speeds higher than 1.1 MB/s? – Lexxer Aug 26 '15 at 8:50
  • @goldilocks: In order to clarify whether the Internet connection might be responsible, I edited my post. – Lexxer Aug 26 '15 at 8:54
0

If you can stream blu-ray to your pi over your local network, the connection from your pi to the local network will not be the bottle neck either.

When you are watching the videos on your laptop, are you using the exact same site and video on your pi? have you tried loading the same youtube video on both to see if there is any noticable differnece?

  • Well, the problem is that the OpenELEC Youtube add-on does not support 1080p, only 780p. So I compared a 1080p internet video stream played via the New York Times add-on on the RPi with the the same 1080p NYT video played via Youtube on my PC. – Lexxer Aug 25 '15 at 12:37
0

As far as I could find out, Internet connection speeds on a RPi 2 running OpenELEC 5.95.4 with default configuration hardly exceed 1.1 MB/s, even if the router is able to go a lot faster.

That is why most Kodi add-ons provide video streams in 780p quality tops -- 1080p requires more than 1.1 MB/s to run smoothly.

So my advice for anybody experiencing trouble with the New York Times Video add-on: Use the add-on to get an overview over the videos NYT provides, then use the Youtube add-on to stream them.

  • I run the current OE Kodi 17 Jarvis testversions, and regularly (also back on kodi 16 builds) get downloads of ~35Mbit, which is the max. bandwith of my service. – ths Aug 27 '15 at 19:36
  • Sorry, i meant 16 rsp. 15, of course... – ths Aug 27 '15 at 20:36
  • @ths: Thanks for the benchmark! Did you use any special configuration? And how did you measure WAN download speeds? – Lexxer Aug 28 '15 at 9:45
  • nothing special, i got download speeds eg. from wget'ing OE testbuilds, and from torrenting. – ths Aug 28 '15 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.