4

I am using Rpi2 installed with ubuntu mate.I've got these speakers but when I plug into the audio 3.5mm jackout there is no response from speakers. The speakers are working fine with other devices.Is it some driver problem or something else with ubuntu mate?.

PS: Ubuntu mate does not have raspi-config feature

  • Have a look at this raspberrypi.org/documentation/configuration/audio-config.md you may need to modify the config file to switch audio output to the av jack since the default is to output sound through the HDMI cable. – Steve Robillard Aug 27 '15 at 6:03
  • @SteveRobillard - Thank you for your reply but I don't have raspbian installed I have ubuntu mate which does not have raspi-config support – Chinmaya B Aug 27 '15 at 7:22
  • Then this is not a raspberry pi question, since your audio does work on the Pi Hardware. Please ask on Ubuntu Exchange or maybe... you speakers are broken.....? – Piotr Kula Aug 27 '15 at 7:52
  • My speakers are working with other devices please read the question again. The problem is that there is no raspi-config to work with or I don't know how to force my audio-out through 3.5mm audio jack. – Chinmaya B Aug 27 '15 at 8:04
  • This might be caused by the HDMI audio output being selected. According to abishur you can change this with: sudo amixer cset numid=3 1. – Thor Aug 27 '15 at 10:30
10

tl;dr

Most likely the Pi is routing the audio through the HDMI port, run the following command to make it use the 3.5mm plug output:

amixer cset name='PCM Playback Route' 1

more detailed answer

Out of the box, the Pi has 2 audio sinks or outputs: HDMI and the 3.5mm plug, if a display is connected the Pi defaults to using HDMI audio. You can change the routing of the audio with amixer from the alsa-utils package.

The amixer program can be used to list and edit various audio settings, e.g. listing controls:

amixer controls

Output:

numid=3,iface=MIXER,name='PCM Playback Route'
numid=2,iface=MIXER,name='PCM Playback Switch'
numid=1,iface=MIXER,name='PCM Playback Volume'
numid=5,iface=PCM,name='IEC958 Playback Con Mask'
numid=4,iface=PCM,name='IEC958 Playback Default'

Getting the value of PCM Playback Route:

amixer cget name='PCM Playback Route'

Output:

numid=3,iface=MIXER,name='PCM Playback Route'
  ; type=INTEGER,access=rw------,values=1,min=0,max=2,step=0
  : values=0

Only the bottom line is interesting here. The numbers that values takes mean the following:

  • 0 = auto
  • 1 = 3.5mm plug
  • 2 = HDMI

So to set the Pi to use the mini-jack plug, run the following command:

amixer cset name='PCM Playback Route' 1

Output:

numid=3,iface=MIXER,name='PCM Playback Route'
  ; type=INTEGER,access=rw------,values=1,min=0,max=2,step=0
  : values=1
| improve this answer | |
1

Just an update to do the same with console-based raspi-config gui:

In terminal type:

sudo raspi config

chose Advanced Options

chose Audio

chose Force 3.5mm

accept with ok then finish.

| improve this answer | |
  • The command needs to be sudo raspi-config. – user72982 Dec 14 '17 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.