0

I get the below error when I do: sudo apt-get upgrade

Please help:

The following packages will be upgraded:
bind9-host cups-bsd cups-client cups-common firmware-realtek fuse hostscript libbind9-80 libcups2 libcupsimage2 libdns88 libexpat1 libfuse2  libgs9 libgs9-common libicu48 libisc84 libisccc80 libisccfg82 liblwres80 libnss3 libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc   libraspberrypi0 libsdl1.2debian libsqlite3-0 libssl1.0.0 openssl raspberrypi-bootloader raspi-config sonic-pi

32 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/121 MB of archives. After this operation, 6,769 kB of additional disk space will be used.

Extracting templates from packages: 100%

Preconfiguring packages ...

Inconsistency detected by ld.so: dynamic-link.h: 190: elf_get_dynamic_info: Assertion `info[20]->d_un.d_val == 17 || info[20]->d_un.d_val == 7' failed!

E: Sub-process /usr/bin/dpkg returned an error code (127)
0

I can confirm this is caused by defective Micro/SD Card or corrupted file system. The solution that work for me is just replace your card with the new one.

  • No guarantee the SD card is the problem – Darth Vader Jul 26 '16 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.