4

I am using ethernet cable to ssh into raspbian, which also has a wifi dongle attached. When I reboot raspbian, it does not connect to wifi and on the desktop in the upper right corner there is an icon which says "dhcpcd not working". If I start dhcpcd manually it connects to wifi without any issues, I can then disconnect ethernet cable and ssh to it through wifi.

But I want to make it connect to wifi automatically, so that I don't have to use the ethernet cable anymore. Is that achievable?

My interface file looks like

auto lo

iface lo inet loopback

auto eth0

allow-hotplug eth0

iface eth0 inet dhcp

auto wlan0 allow-hotplug wlan0

iface wlan0 inet manual wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

  • Your Pi has a wireless dongle to presumably talk to a wireless router. The wireless router should be acting as the DHCP server and give the dongle an IP address. You should not need to start a server on your Pi. What is this dhcpd program you are starting? – joan Aug 31 '15 at 14:51
  • @joan Sorry, I'm new to linux. I was using windowed mode through vnc and in the upper right corner of the desktop on rpi there was an icon which said "dhcpcd not working". When I start dhcpcd this icon gets reply by wifi logo and everything connects normally. – user20997 Aug 31 '15 at 14:54
  • I'm afraid that means nothing to me as I don't use VNC. Hopefully someone will come along who understands what is going on. – joan Aug 31 '15 at 14:55
  • I don't think that this has anything to do with VNC, pretty sure that if I connected an external monitor to rpi it would show me the same thing. – user20997 Aug 31 '15 at 14:57
3

I had a problem with: lxde and DHCPCD is not running. I could correct by opening a terminal window and entering $ sudo dhcpcd, but this wasn't persistent across reboots.

When your system is starting, do you see:

  • [FAIL] Not running dhcpcd because /etc/network/interfaces ... failed!
  • [FAIL] defines some interfaces that will use a DHCP client ... failed!

These will appear after DHCPDISCOVER and just before your X terminal starts. Use ctrl-s to stop the display, and ctrl-q to continue.

If you see this, then to correct, open a terminal:

$ sudo nano /etc/network/interfaces

and replace dhcp with manual. The two lines from your interfaces are:

  • iface eth0 inet manual
  • iface default inet manual

then reboot

0

i had similar issue i was able to fixed running these commands:

sudo systemctl disable dhcpcd.service
sudo systemctl reboot

the issue seems to be that is that dhcpcd.service is being installed in some update and is not compatible with /etc/network/interfaces

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.