0

After a few hours unattended, powered by a spare microUSB phone charger, my pi loses connectivity and stops running scripts, which don't depend on internet connectivity.

An example of a process/script that will stop running is a crontab call every 5 minutes to a script in /usr/local/bin that checks on an init.d process. Whenever my connectivity cuts out, so does everything it seems. In fact, the logs I've tried to throw together only report good outcomes, i.e. 'process x is running.' Whenever stuff cuts out, there is just nothing logged.

What might be happening?

I'd note I had everything working on a smaller sd card by the same manufacturer, and decided to move everything to a larger sd card.

I am connected to WiFi by on of the Edimax dongles.

  • 1
    Sounds like you may have a power issue. Don't go by the label on the charger to really diagnose the problem you will need a multimeter and test on the actual board. You dont't mention what model Pi you have but the link should cover it elinux.org/R-Pi_Troubleshooting#Troubleshooting_power_problems – Steve Robillard Aug 31 '15 at 22:06
  • What is most likely cause of power problems? The charger itself? – cfye14 Aug 31 '15 at 22:16
  • Yes, the charger that is why I said not to trust the label and test to be sure. I had this problem and a search of this site and the web in general will show lots of problems traced back to power issues. BTW are you connected with the dashboard app cyfe? – Steve Robillard Aug 31 '15 at 22:39
  • yeah, I have one cable that sits around 4.8 V and another at 4.9 volts and that appears to make all the difference. – cfye14 Sep 18 '15 at 21:00
  • You should answer your own question. and accept it (I think you need to wait 2 days to accept it). – Steve Robillard Sep 18 '15 at 21:13
2

The solution was to use a different cable that averaged closer to 4.9 volts rather than 4.8 volts. No issues since finding a cable setup that worked better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.