1

Sometimes I switch between putty and working directly on the pi (with an extra monitor). This time I used putty and typed in "logout" by mistake. Putty closed immediately.

Then I tried to open a new session with putty as I do before. I got the error "Network Error: Connection refused" in a pop up window. So I connected the monitor and entered raspi-config, thought the SSH remote access was disabled.

But when I'm trying to enable it I get the error "There was an error running option A4 SSH". The same comes up when trying to disable it.

What happened here and how can I reactivate the remote SSH access?

  • Have you rebooted the Pi? Have you tried restarting the SSH service? You can do this from the command line with the following sudo service ssh restart, watch for any error messages. If you get an error please update your question. – Steve Robillard Sep 6 '15 at 2:58
  • @SteveRobillard : Yes, I rebooted and restarted the service, but it still didn't work. I'm sorry, I can't tell you the excact error message because I recovered the whole Pi yesterday. But it still would be interesting to know what kind of fault causes this behavior. Thank you – timdelawe Sep 7 '15 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.