I got my Pi today and having a lot of fun with it (it's the coolest computer I've owned, and I had a lot of comupters...). I had some problems with mp3 playback though but due to my own fault.

I have installed mpg123 and I can play music ok from the command prompt without having started x I could play music by entering:

mpg123 <mysong>.mp3 

However once I started x this only worked if I entered:

sudo mpg123 <mysong>.mp3

I remembered that when renaming the pi user to my user something went wrong and I simply created a new user for myself. This new user did not have the required audio group membership. Once I fixed that mp3 playback worked fine with and without x.

However I do wonder why without beeing in the group audio I could playback music from the command line without the sudo. Does anybody have any idea on this?

Best Regards,


  • 1
    Could you please post more and detail error so that we can help ? Commented Nov 10, 2012 at 7:47
  • You need to be in the audio group.
    – Jivings
    Commented Nov 10, 2012 at 11:12

1 Answer 1


The command is only accessible to users in the audio group:

stat -c %G $(which mpg123)

You can add yourself to that group like this:

gpasswd -a [user] audio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.