I have a Raspberry pi B, using Debian, just rigged up with a 3.5 inch TFT-LCD monitor via VGA. The text size in command line mode is too small to read, so I would like to increase its size, and one method says "edit /boot/config.txt". However the command ls /boot shows no config.txt -- the only .txt file is cmdline.txt.

Another method ref: http://www.raspberrypi-spy.co.uk/2012/11/cheap-miniature-lcd-screen which says use sudo dpkg-reconfigure console-setup doesn't seem to make any difference.

Have I done something wrong? I'd appreciate any help in progressing forward from here.

7 Answers 7


I have this problem, too, when I'm using my huge TV. Try this:

setfont /usr/share/consolefonts/Lat15-TerminusBold20x10.psf.gz

To see a list of available fonts: ls /usr/share/consolefonts/

The numbers at the end indicate width and height (though not always that exact!)

No idea why config.txt is missing. However, you can use this:


as a template for creating a new one.

My guess would be that a) it's been deleted accidentally or b) has been corrupted in some way in the file system and has disappeared. (a is more likely)

  • Thank you recantha, that worked very well. That problem solved nicely, but I still don't understand why config.txt is missing. Looking this gift horse straight in the mouth, the font now is a bit too big, so: is there a way to see other available fonts? Nov 9, 2012 at 19:09
  • Edited my original to answer additional question.
    – recantha
    Nov 10, 2012 at 4:57
  • How would this be put into /boot/config.txt? Mine (from OSMC 2016.05-1) doesn't contain any line looking like it, and this Raspbian config.txt article doesn't, either ...
    – Tobias
    Jun 19, 2016 at 21:18

You can use setfont from a terminal to set the current console font to one of the fonts found in /usr/share/consolefonts/. You don't need to specify the full path or the .psf.gz suffix. Just something like:

setfont Lat15-Fixed18

will do the trick. You can play around until you find a font you like, and then to make it systemwide and default, you can specify it in /etc/kbd/config as the kbd package/service takes it upon itself to monkey with the console font during startup.

As a side note, you may find the you have to create a custom entry in /etc/fb.modes to get a native resolution on the small screen so the display looks nice and crisp.

  • For anyone running Centos 7, the directory is /lib/kbd/consolefonts. May 9, 2019 at 1:42

7 years later, I was having the same issue, and the solution that worked for me was "Method 2" from https://www.raspberrypi-spy.co.uk/2014/04/how-to-change-the-command-line-font-size/.

In short, I did sudo nano /etc/default/console-setup and updated the FONTFACE and FONTSIZE fields to the size I wanted:


Then I saved the file and rebooted the pi.

The benefit of doing it this way is that it works from the moment the device boots, instead of only kicking in after I log in (as with the answers that use .profile).

Incidentally, to figure out what values to use for font face and size, I looked in the /usr/share/consolefonts/ directory (as suggested above), and went from there.


Here's the simplest solution: When you log in to Linux (or Unix) a file named .profile is executed by the shell. I recently got a 7" LCD, 1024x600 monitor. For the last 2 years I've communicated with my Rpi through ssh, but now I needed a system with a small monitor. So I edited the .profile file and added the following line at the end:

setfont /usr/share/consolefonts/Uni3-Terminus28x14.pst.gz

A 14x28 pixel font that works for me. There many (hundreds of) fonts. If you like a bit smaller try 24x12 or bigger 32x16.

  • I suppose "command line mode" in the OP was referring to LXTerminal, but I took it as console mode with no GUI.
    – bobstro
    Jul 24, 2015 at 3:21
  • I'm quite sure the non-gui console mode was meant alright. This works for me; I appended my setfont line to the end of my osmc users .profile. The little downside is, during login I still have my wrong font size; thus, it would be better to solve this in system rather than user settings. But this solution is far better than nothing, of course.
    – Tobias
    Jun 19, 2016 at 21:14

Clicking on the "edit" tab in LXTerminal --> Go to preferences --> Click on "Style" tab --> Here you can change your font, size, color & background


The easiest way is to right-click inside the terminal window and select...


In the "Style" tab select top item "Terminal font" by clicking on the name of the font displayed in that field. Then select the font you want and its size using the selection pop-up window.

You can even search for a specific font like "mono" or "sans" in the search field.


The answers of PicktownBuckeye and iDug are the best for me. the solution they give is good for me, previously I had to get very close to my TV screen ! I do not understand why they are noted 0 ( I tried the other with no success to increase fonts on my Samsung TV screen). Look at the number at right of the font and increase it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.