5

I get this error while running sudo apt-get update

Hit http://mirrordirector.raspbian.org wheezy InRelease
Hit http://archive.raspberrypi.org wheezy InRelease
Hit http://archive.raspberrypi.org wheezy/main armhf Packages
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Get:1 http://mirrordirector.raspbian.org wheezy/main armhf Packages [7379 kB]
100% [1 Packages 7379 kB/7379 kB 100%]Failed to exec method /usr/lib/apt/methods/bzip2
E: Method bzip2 has died unexpectedly!
E: Sub-process bzip2 returned an error code (100)
E: Method /usr/lib/apt/methods/bzip2 did not start correctly

What can it be? This is what I have in my /etc/apt/sources.list

deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
11
  • Is it possible for you to translate those errors to English?
    – Jivings
    Nov 10 '12 at 14:19
  • @Jivings My edit for that is pending ... Nov 10 '12 at 15:53
  • I run RaspBMC and it contains deb http://archive.raspbian.org/raspbian wheezy main contrib non-free in /etc/apt/sources.list Nov 10 '12 at 19:26
  • Did you run apt-get upgrade first? Looks like it's an error with your mirrorlist.
    – Jivings
    Nov 11 '12 at 14:00
  • upgrade doensn't return any error. i've also tried clean with no success
    – G3z
    Nov 11 '12 at 14:30
1

In the end it was a filesystem issue! I ended up repairing the FS in ubuntu with fsck -y /dev/sdb and then reinstalling apt manualy as plugwash from RaspberryPi Forum suggested

sudo wget http://archive.raspbian.org/raspbian/pool/main/a/apt/libapt-pkg4.12_0.9.7.6+rpi1_armhf.deb
sudo wget http://archive.raspbian.org/raspbian/pool/main/a/apt/apt_0.9.7.6+rpi1_armhf.deb
sudo dpkg -i libapt-pkg4.12_0.9.7.6+rpi1_armhf.deb apt_0.9.7.6+rpi1_armhf.deb
sudo apt-get update 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.