A few days ago I connected my Raspberry Pi to my screen and I did some work directly on it (without GUI, thus only command line) and suddenly it crashed / shutdown.

The red light is on all the time. Today I tried with a bit of trial and error and I tried to run it with ethernet and power source connected, it happened again. Then I tried to connect almost everything except ethernet (mouse, keyboard and power). Then it stayed on-line all the time (a few hours) then I added the ethernet cable and it then after a few minutes crashed with only the red light appearing. (I can see from the light in my mouse (red laser light) that it was on before and then when I connected it to the ethernet it, after a while, didn't show its red laser light anymore. I also tried to reinstall Raspbian, didn't help.

Has anyone ever tried anything like this? Does the Raspberry Pi keep a failure log in which I could look at? Or anything else?

Update-I tried using another power source ( a garmin charger supplying 1A ) and yet again the pi crashed after sometime.So we can possibly rule out this being a power issue.

  • How is your Pi being powered and have you overclocked it? Nov 10, 2012 at 21:09
  • I have not overclocked it. I memory splitted (32 to GPU) and expanded its roots. I am powering it through an Apple iPhone charger and a usb->micro USB cable.
    – mikkeljuhl
    Nov 10, 2012 at 21:16
  • What is the output power of that iPhone charger?
    – ikku
    Nov 10, 2012 at 21:32
  • 5V == 1A, which should be alright, shouldn't it?
    – mikkeljuhl
    Nov 10, 2012 at 21:35
  • 2
    @mikkeljuhl 1A should be alright.However, you should test with another power source before ruling that out.A lot of Fake apple chargers have already caused trouble with pi.
    – SteveIrwin
    Nov 10, 2012 at 21:38

1 Answer 1


Mine was doing something similar but I found the cause.

1) The Ethernet cable I was using had a broken clip, and so the plug kept slipping out. All the other lights go off, because they are all to do with the link status. If the cable is disconnected, there is no link so only the red power-light stays on. Mine however didn't crash, I just pushed the plug fully home and all was restored.

2) If your Ethernet connection is supplying power over Ethernet (Mine does as I have VoIP phones) that can cause you a few hiccups, shouldn't be anything major though.

Sounds to me mostly like the plug is coming loose, loosing the connection then some app expecting the connection / link to be there is bringing the OS down when the connection is lost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.