2

I have RPi with usb soundcard I have follow this answer USB card as my default Audio Device But i still can't make it work the settings always changing itself and i can't set my default soundcard to my usbsoundcard

there is no sound if I put my speaker to the usb soundcard but it have when I put it to default rapsberry 3.5mm jack out

I test it via aplay

my lsub

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

my alsa-base.conf

# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
options snd_bcm2835 index=1
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

update It seems like my rpi won't produce sound if I remove my usb sound card when I remove my usb sound card I can't execute amixer/alsamixer it returns cannot open mixer: No such file or directory

0

The trick is is in ~/.asoundrc

If you have already gone into /etc/modprobe.d/alsa-base.conf and changed options snd-usb-audio index=-2 to options snd-usb-audio index=0 then:

First:

sudo nano ~/.asoundrc

Second:

Add

pcm.!default {
    type hw
    card 0
}

ctl.!default {
    type hw
    card 0
}

Then save and reboot your Pi.

This works because when you add options snd-usb-audio index=0 to /etc/modprobe.d/alsa-base.conf it only sets your usb card at index 0, it doesn't enable it.

Cheers!

  • why when i change the value to 1 when i reboot it always get back to 0, i have remove my settings in alsa-base.conf – buncis Sep 8 '15 at 14:34
0

so today i can make my rpi to use the usb soundcard the workaround is

Reinstall my rapsbian with noobs
uncomment one line in alsa-base.conf

# Keep snd-usb-audio from beeing loaded as first soundcard
# options snd-usb-audio index=-2

and never ever go to GUI/startx
(I'm not sure about this one but when i run startx the amixer settings is changing itself)

now the aplay and arecord working flawlessy

0

I have read idea about sound card. May be help u. Pi 2 Design is excited to introduce the first Tube Amp specifically designed for any of the 40-pin versions of the Raspberry Pi SBC Family. The 503HTA Hybrid Tube Amp HAT, designed and manufactured by Pi2Media (a division of PI 2 Design), is a High Quality I/O Shield designed to bring “Sweet Tube Sound” to the Raspberry PI ® family of Single Board Computers. This HAT allows the Raspberry Pi ® SBC to drive Headphones from 32 – 300 ohm with ease and fidelity.

Based on the popular Bravo V2 design with all recommended Mods, the On-Board PCM5102A DAC drives the single stage 12AU7 (or 6922) tube. The Class-A Output Stage is comprised of the IRL510 and LM317A. The dedicated heater supply insures zero crosstalk. Source: http://ubuntu4u.info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.