0

I am using a raspberry Pi 2 with a Realtek wifi dongle using 8188eufw firmware downloaded from here I have run lsusb and it registered my dongle. The problem is that when I plug the dongle in it disconnects my other usb devices such as my mouse and keyboard. I think this may be a power issue? Is it or do I have some other issue? Also I have an issue connecting to the Internet when it doesn't disconnect my mouse and keyboard. It doesn't connect to the Internet possibly because the normal wpa app that comes with raspian wasn't there. I used the network configuration tool in the toolbar but didn't know whether the 'Ip address' it asked for was external or something else. Pls help I'm desperate. Nothing seems to fix it and I've looked through everything.

3
  • This could be power related (especially since you lose the keyboard and mouse). First step to diagnosing this would be to connect the WiFi dongle to the Pi using a powered hub. As for the IP question can you edit your question and include a screenshot. Commented Sep 8, 2015 at 10:58
  • How do you have any suggestions for a hub I co use? Commented Sep 8, 2015 at 11:13
  • this should help you pick a hub elinux.org/RPi_Powered_USB_Hubs Commented Sep 8, 2015 at 11:14

1 Answer 1

0

This is definitely power related. Have you modified the setting in the boot config that gives the USB ports more power? If not then make sure that that's on. I believe the file is /boot/config. It must be something like that. The setting is something like max_USB_current.

4
  • Thanks I think that this might work but will it effect the performance of the Pi? I'm powering from a TV port. Commented Sep 8, 2015 at 21:49
  • Everything should be just fine, since you power down correctly.
    – Triforcey
    Commented Sep 8, 2015 at 21:50
  • max_usb_current is not listed in /boot/config.txt and other sites say it should be. Do I add it in? Commented Sep 8, 2015 at 22:13
  • Yes, you should.
    – Triforcey
    Commented Sep 8, 2015 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.