3

I'll start by saying that I probably shorted something to cause this.

I noticed this behavior the next morning after spilling some water next to it. I didn't think any got on it through the holes in its case, but I'm thinking I may be wrong about that.

Now the green ACT light blinks 4 times in sequence when plugged in.

Raspberry Pi model B 512mb running headless piCore player

I have:

  1. Removed the SD card that was in it and successfully booted another Pi up with that card.
  2. Re-imaged another (previously tested) SD card with Win32diskimager with a fresh copy of a previously tested Raspbian image.
  3. Placed the Pi on 3 other power supplies. All previously tested to work on this and other Pi's.
  4. Verified that the voltage between TP1 and TP2 is approximately 4.93vdc.
  5. Tried it with nothing plugged in besides SD card and power.
  6. Tried the card with Raspbian on it hooked up to HDMI - no signal getting to the display.
  7. Left it on and blinking for an hour - normal temperature when I checked it.

I don't see any visually obvious discolorations or other failures.

Is there anything else I can check or do with it before tossing it?

  • Is it functional other than the blinking ACT light? – Patrick Cook Sep 9 '15 at 1:58
  • I am sure you must have looked at this one. Still pointing it out. raspberrypi.stackexchange.com/questions/10579/… – dhruvvyas90 Sep 9 '15 at 7:25
  • Could you describe the blinking. Just four times at boot has a specific meaning. Four times and a gap repeatedly means something else. – joan Sep 9 '15 at 9:46
  • @dastaan I have seen that link - which is part of why I am hovering around concluding that it is shorted. – Praxis Sep 10 '15 at 2:39
  • @PatrickCook The red power LED is steady, otherwise nothing else functions beyond the blinking ACT light. No video when hooked up to monitor, no network activity. – Praxis Sep 10 '15 at 2:40
1

This topic on RPi forum gives the following information about blinking ACT led:

  • 3 flashes: loader.bin not found
  • 4 flashes: loader.bin not launched
  • 5 flashes: start.elf not found
  • 6 flashes: start.elf not launched

"Not launched" usually means the file is corrupt. I'm not sure how loader.bin gets damaged considering you've done a reflash before testing. Make sure you're following whatever "Safe removal" procedure is offered by your OS, and run a filesystem check after flashing the image to be sure.

0

I know this is very old, but I will answer anyway. I think you damaged one of the parts the Raspberry Pi uses to run the SD card's filesystem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.